summaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-08-19 10:52:13 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2012-08-20 22:51:54 +0200
commitf3e8eac6dfe7a04cb6aae829a4b432bcdd4b4916 (patch)
tree087e198f29caee85204aff3e205f5f1c06bba6cb /meta-systemd/oe-core
parent72f8ed45570c55c7dc293996ef793253ab8510a8 (diff)
downloadmeta-openembedded-f3e8eac6dfe7a04cb6aae829a4b432bcdd4b4916.tar.gz
pulseaudio: remove bbappend
oe-core has updated to 2.1 which includes the appended patch Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd/oe-core')
-rw-r--r--meta-systemd/oe-core/recipes-multimedia/pulseaudio/pulseaudio/pulseaudio-2.0-udev-symbols.patch80
-rw-r--r--meta-systemd/oe-core/recipes-multimedia/pulseaudio/pulseaudio_2.0.bbappend5
2 files changed, 0 insertions, 85 deletions
diff --git a/meta-systemd/oe-core/recipes-multimedia/pulseaudio/pulseaudio/pulseaudio-2.0-udev-symbols.patch b/meta-systemd/oe-core/recipes-multimedia/pulseaudio/pulseaudio/pulseaudio-2.0-udev-symbols.patch
deleted file mode 100644
index 1ad720b99..000000000
--- a/meta-systemd/oe-core/recipes-multimedia/pulseaudio/pulseaudio/pulseaudio-2.0-udev-symbols.patch
+++ /dev/null
@@ -1,80 +0,0 @@
1From 2e64edbd3e12145950ccd952bb7984a4420b8c02 Mon Sep 17 00:00:00 2001
2From: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
3Date: Thu, 17 May 2012 22:50:22 +0200
4Subject: [PATCH] udev: Don't use deprecated udev_get_*_path() functions
5
6[These symbols were removed in libudev.so.1.0.0. Replace them with
7hardcoded strings. -- heftig]
8
9Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
10---
11 src/modules/module-udev-detect.c | 9 +++------
12 src/modules/udev-util.c | 4 ++--
13 2 files changed, 5 insertions(+), 8 deletions(-)
14
15diff --git a/src/modules/module-udev-detect.c b/src/modules/module-udev-detect.c
16index 1192194..31416bd 100644
17--- a/src/modules/module-udev-detect.c
18+++ b/src/modules/module-udev-detect.c
19@@ -123,7 +123,7 @@ static char *card_get_sysattr(const char *card_idx, const char *name) {
20 goto finish;
21 }
22
23- t = pa_sprintf_malloc("%s/class/sound/card%s", udev_get_sys_path(udev), card_idx);
24+ t = pa_sprintf_malloc("/sys/class/sound/card%s", card_idx);
25 card = udev_device_new_from_syspath(udev, t);
26 pa_xfree(t);
27
28@@ -282,7 +282,7 @@ static void verify_access(struct userdata *u, struct device *d) {
29 pa_assert(u);
30 pa_assert(d);
31
32- cd = pa_sprintf_malloc("%s/snd/controlC%s", udev_get_dev_path(u->udev), path_get_card_id(d->path));
33+ cd = pa_sprintf_malloc("/dev/snd/controlC%s", path_get_card_id(d->path));
34 accessible = access(cd, R_OK|W_OK) >= 0;
35 pa_log_debug("%s is accessible: %s", cd, pa_yes_no(accessible));
36
37@@ -621,7 +621,6 @@ fail:
38 }
39
40 static int setup_inotify(struct userdata *u) {
41- char *dev_snd;
42 int r;
43
44 if (u->inotify_fd >= 0)
45@@ -632,9 +631,7 @@ static int setup_inotify(struct userdata *u) {
46 return -1;
47 }
48
49- dev_snd = pa_sprintf_malloc("%s/snd", udev_get_dev_path(u->udev));
50- r = inotify_add_watch(u->inotify_fd, dev_snd, IN_ATTRIB|IN_CLOSE_WRITE|IN_DELETE_SELF|IN_MOVE_SELF);
51- pa_xfree(dev_snd);
52+ r = inotify_add_watch(u->inotify_fd, "/dev/snd", IN_ATTRIB|IN_CLOSE_WRITE|IN_DELETE_SELF|IN_MOVE_SELF);
53
54 if (r < 0) {
55 int saved_errno = errno;
56diff --git a/src/modules/udev-util.c b/src/modules/udev-util.c
57index 2f18bc4..b0bb17d 100644
58--- a/src/modules/udev-util.c
59+++ b/src/modules/udev-util.c
60@@ -180,7 +180,7 @@ int pa_udev_get_info(int card_idx, pa_proplist *p) {
61 goto finish;
62 }
63
64- t = pa_sprintf_malloc("%s/class/sound/card%i", udev_get_sys_path(udev), card_idx);
65+ t = pa_sprintf_malloc("/sys/class/sound/card%i", card_idx);
66 card = udev_device_new_from_syspath(udev, t);
67 pa_xfree(t);
68
69@@ -277,7 +277,7 @@ char* pa_udev_get_property(int card_idx, const char *name) {
70 goto finish;
71 }
72
73- t = pa_sprintf_malloc("%s/class/sound/card%i", udev_get_sys_path(udev), card_idx);
74+ t = pa_sprintf_malloc("/sys/class/sound/card%i", card_idx);
75 card = udev_device_new_from_syspath(udev, t);
76 pa_xfree(t);
77
78--
791.7.8.6
80
diff --git a/meta-systemd/oe-core/recipes-multimedia/pulseaudio/pulseaudio_2.0.bbappend b/meta-systemd/oe-core/recipes-multimedia/pulseaudio/pulseaudio_2.0.bbappend
deleted file mode 100644
index 3e8136541..000000000
--- a/meta-systemd/oe-core/recipes-multimedia/pulseaudio/pulseaudio_2.0.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "file://pulseaudio-2.0-udev-symbols.patch"
4
5PRINC := "${@int(PRINC) + 1}"