summaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-extended
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-systemd/oe-core/recipes-extended
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-systemd/oe-core/recipes-extended')
-rw-r--r--meta-systemd/oe-core/recipes-extended/at/at/atd.service9
-rw-r--r--meta-systemd/oe-core/recipes-extended/at/at_%.bbappend16
-rw-r--r--meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend4
-rw-r--r--meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_%.bbappend3
-rw-r--r--meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_%.bbappend3
5 files changed, 35 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-extended/at/at/atd.service b/meta-systemd/oe-core/recipes-extended/at/at/atd.service
new file mode 100644
index 000000000..64a901550
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/at/at/atd.service
@@ -0,0 +1,9 @@
1[Unit]
2Description=Job spooling tools
3After=syslog.target
4
5[Service]
6ExecStart=/usr/sbin/atd -f
7
8[Install]
9WantedBy=multi-user.target
diff --git a/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend b/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend
new file mode 100644
index 000000000..3a22fe3bd
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend
@@ -0,0 +1,16 @@
1inherit systemd
2
3# look for files in the layer first
4FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
5
6SRC_URI += "file://atd.service"
7
8RPROVIDES_${PN} += "${PN}-systemd"
9RREPLACES_${PN} += "${PN}-systemd"
10RCONFLICTS_${PN} += "${PN}-systemd"
11SYSTEMD_SERVICE_${PN} = "atd.service"
12do_install_append() {
13 install -d ${D}${systemd_unitdir}/system
14 install -m 0644 ${WORKDIR}/atd.service ${D}${systemd_unitdir}/system
15}
16
diff --git a/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend
new file mode 100644
index 000000000..181b8784d
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend
@@ -0,0 +1,4 @@
1RPROVIDES_${PN} += "${PN}-systemd"
2RREPLACES_${PN} += "${PN}-systemd"
3RCONFLICTS_${PN} += "${PN}-systemd"
4
diff --git a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_%.bbappend b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_%.bbappend
new file mode 100644
index 000000000..f006b3fb5
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_%.bbappend
@@ -0,0 +1,3 @@
1RPROVIDES_${PN} += "${PN}-systemd"
2RREPLACES_${PN} += "${PN}-systemd"
3RCONFLICTS_${PN} += "${PN}-systemd"
diff --git a/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_%.bbappend b/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_%.bbappend
new file mode 100644
index 000000000..f006b3fb5
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_%.bbappend
@@ -0,0 +1,3 @@
1RPROVIDES_${PN} += "${PN}-systemd"
2RREPLACES_${PN} += "${PN}-systemd"
3RCONFLICTS_${PN} += "${PN}-systemd"