summaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-extended
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-10 03:20:04 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-10 03:20:04 +0200
commit1b8dfe266937a37a4c642f96ceb2347bf4c00a17 (patch)
tree0c6aab146bb3c82efd9c7846a9a4e70dcb0ec84f /meta-systemd/oe-core/recipes-extended
downloadmeta-openembedded-1b8dfe266937a37a4c642f96ceb2347bf4c00a17.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-systemd/oe-core/recipes-extended')
-rw-r--r--meta-systemd/oe-core/recipes-extended/at/at/atd.service9
-rw-r--r--meta-systemd/oe-core/recipes-extended/at/at_3.1.14.bbappend16
-rw-r--r--meta-systemd/oe-core/recipes-extended/cronie/cronie/crond.service10
-rw-r--r--meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend17
-rw-r--r--meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_%.bbappend3
-rw-r--r--meta-systemd/oe-core/recipes-extended/pam/libpam_1.1.6.bbappend4
-rw-r--r--meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_%.bbappend3
7 files changed, 62 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-extended/at/at/atd.service b/meta-systemd/oe-core/recipes-extended/at/at/atd.service
new file mode 100644
index 000000000..64a901550
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/at/at/atd.service
@@ -0,0 +1,9 @@
1[Unit]
2Description=Job spooling tools
3After=syslog.target
4
5[Service]
6ExecStart=/usr/sbin/atd -f
7
8[Install]
9WantedBy=multi-user.target
diff --git a/meta-systemd/oe-core/recipes-extended/at/at_3.1.14.bbappend b/meta-systemd/oe-core/recipes-extended/at/at_3.1.14.bbappend
new file mode 100644
index 000000000..3a22fe3bd
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/at/at_3.1.14.bbappend
@@ -0,0 +1,16 @@
1inherit systemd
2
3# look for files in the layer first
4FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
5
6SRC_URI += "file://atd.service"
7
8RPROVIDES_${PN} += "${PN}-systemd"
9RREPLACES_${PN} += "${PN}-systemd"
10RCONFLICTS_${PN} += "${PN}-systemd"
11SYSTEMD_SERVICE_${PN} = "atd.service"
12do_install_append() {
13 install -d ${D}${systemd_unitdir}/system
14 install -m 0644 ${WORKDIR}/atd.service ${D}${systemd_unitdir}/system
15}
16
diff --git a/meta-systemd/oe-core/recipes-extended/cronie/cronie/crond.service b/meta-systemd/oe-core/recipes-extended/cronie/cronie/crond.service
new file mode 100644
index 000000000..5ae193bfc
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/cronie/cronie/crond.service
@@ -0,0 +1,10 @@
1[Unit]
2Description=Periodic Command Scheduler
3
4[Service]
5ExecStart=/usr/sbin/crond -n
6ExecReload=/bin/kill -HUP $MAINPID
7Restart=always
8
9[Install]
10WantedBy=multi-user.target
diff --git a/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend
new file mode 100644
index 000000000..8f45f3ee5
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend
@@ -0,0 +1,17 @@
1# look for files in the layer first
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3
4inherit systemd
5
6RPROVIDES_${PN} += "${PN}-systemd"
7RREPLACES_${PN} += "${PN}-systemd"
8RCONFLICTS_${PN} += "${PN}-systemd"
9SYSTEMD_SERVICE_${PN} = "crond.service"
10
11SRC_URI += "file://crond.service"
12
13do_install_append() {
14 install -d ${D}${systemd_unitdir}/system
15 install -m 0644 ${WORKDIR}/crond.service ${D}${systemd_unitdir}/system
16}
17
diff --git a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_%.bbappend b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_%.bbappend
new file mode 100644
index 000000000..f006b3fb5
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_%.bbappend
@@ -0,0 +1,3 @@
1RPROVIDES_${PN} += "${PN}-systemd"
2RREPLACES_${PN} += "${PN}-systemd"
3RCONFLICTS_${PN} += "${PN}-systemd"
diff --git a/meta-systemd/oe-core/recipes-extended/pam/libpam_1.1.6.bbappend b/meta-systemd/oe-core/recipes-extended/pam/libpam_1.1.6.bbappend
new file mode 100644
index 000000000..db5508209
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/pam/libpam_1.1.6.bbappend
@@ -0,0 +1,4 @@
1# Register with logind to make screen/tmux/etc work
2do_install_append() {
3 echo "session required pam_systemd.so" >> ${D}${sysconfdir}/pam.d/common-session
4}
diff --git a/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_%.bbappend b/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_%.bbappend
new file mode 100644
index 000000000..f006b3fb5
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_%.bbappend
@@ -0,0 +1,3 @@
1RPROVIDES_${PN} += "${PN}-systemd"
2RREPLACES_${PN} += "${PN}-systemd"
3RCONFLICTS_${PN} += "${PN}-systemd"