summaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-core
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-systemd/oe-core/recipes-core
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd/oe-core/recipes-core')
-rw-r--r--meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend12
-rw-r--r--meta-systemd/oe-core/recipes-core/dropbear/dropbear_2012.55.bbappend10
2 files changed, 11 insertions, 11 deletions
diff --git a/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend b/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend
index cd6acc826..bdba2db3c 100644
--- a/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend
+++ b/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend
@@ -12,13 +12,13 @@ SYSTEMD_PACKAGES = "${PN}-syslog"
12SYSTEMD_SERVICE_${PN}-syslog = "busybox-syslog.service" 12SYSTEMD_SERVICE_${PN}-syslog = "busybox-syslog.service"
13 13
14do_install_append() { 14do_install_append() {
15 install -d ${D}${systemd_unitdir}/system 15 install -d ${D}${systemd_unitdir}/system
16 sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-syslog.service.in \ 16 sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-syslog.service.in \
17 > ${D}${systemd_unitdir}/system/busybox-syslog.service 17 > ${D}${systemd_unitdir}/system/busybox-syslog.service
18 sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-klogd.service.in \ 18 sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-klogd.service.in \
19 > ${D}${systemd_unitdir}/system/busybox-klogd.service 19 > ${D}${systemd_unitdir}/system/busybox-klogd.service
20 20
21 ln -sf /dev/null ${D}${systemd_unitdir}/system/syslog.service 21 ln -sf /dev/null ${D}${systemd_unitdir}/system/syslog.service
22} 22}
23FILES_${PN}-syslog += "${systemd_unitdir}/system/syslog.service" 23FILES_${PN}-syslog += "${systemd_unitdir}/system/syslog.service"
24 24
diff --git a/meta-systemd/oe-core/recipes-core/dropbear/dropbear_2012.55.bbappend b/meta-systemd/oe-core/recipes-core/dropbear/dropbear_2012.55.bbappend
index 23e282000..edaa66ed4 100644
--- a/meta-systemd/oe-core/recipes-core/dropbear/dropbear_2012.55.bbappend
+++ b/meta-systemd/oe-core/recipes-core/dropbear/dropbear_2012.55.bbappend
@@ -15,9 +15,9 @@ RCONFLICTS_${PN} += "${PN}-systemd"
15SYSTEMD_SERVICE_${PN} = "dropbear.socket" 15SYSTEMD_SERVICE_${PN} = "dropbear.socket"
16 16
17do_install_append() { 17do_install_append() {
18 install -d ${D}${systemd_unitdir}/system 18 install -d ${D}${systemd_unitdir}/system
19 install -m 0644 ${WORKDIR}/dropbearkey.service ${D}${systemd_unitdir}/system 19 install -m 0644 ${WORKDIR}/dropbearkey.service ${D}${systemd_unitdir}/system
20 install -m 0644 ${WORKDIR}/dropbear@.service ${D}${systemd_unitdir}/system 20 install -m 0644 ${WORKDIR}/dropbear@.service ${D}${systemd_unitdir}/system
21 install -m 0644 ${WORKDIR}/dropbear.socket ${D}${systemd_unitdir}/system 21 install -m 0644 ${WORKDIR}/dropbear.socket ${D}${systemd_unitdir}/system
22 ln -sf /dev/null ${D}${systemd_unitdir}/system/dropbear.service 22 ln -sf /dev/null ${D}${systemd_unitdir}/system/dropbear.service
23} 23}