summaryrefslogtreecommitdiffstats
path: root/meta-systemd/meta-oe
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-06-10 21:46:51 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-07-16 09:39:07 +0200
commitc203043683deff90b4d80c326bf6b27a28a59386 (patch)
treebf6aa8e0e30de5a21f3d89a0a4bbefb7f6b99d16 /meta-systemd/meta-oe
parent365d5ec941347f54744b9f5fbb7b06cc3949e14a (diff)
downloadmeta-openembedded-c203043683deff90b4d80c326bf6b27a28a59386.tar.gz
cherokee: move systemd support to meta-systemd
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-systemd/meta-oe')
-rw-r--r--meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service10
-rw-r--r--meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bbappend10
2 files changed, 20 insertions, 0 deletions
diff --git a/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service b/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service
new file mode 100644
index 000000000..a2d703185
--- /dev/null
+++ b/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service
@@ -0,0 +1,10 @@
1[Unit]
2Description=Cherokee web server
3After=syslog.target
4
5[Service]
6Type=forking
7ExecStart=/usr/sbin/cherokee -d -C /etc/cherokee/cherokee.conf
8
9[Install]
10WantedBy=multi-user.target
diff --git a/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bbappend b/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bbappend
new file mode 100644
index 000000000..7cc7dd847
--- /dev/null
+++ b/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bbappend
@@ -0,0 +1,10 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3PRINC := "${@int(PRINC) + 1}"
4
5inherit systemd
6
7SRC_URI += "file://cherokee.service"
8
9SYSTEMD_PACKAGES = "${PN}-systemd"
10SYSTEMD_SERVICE = "cherokee.service"