summaryrefslogtreecommitdiffstats
path: root/meta-systemd/meta-oe/recipes-extended/zram
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-02-13 17:25:35 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-12 18:49:55 +0200
commit313f0ae25925caead4f588695ac9c9bcf00b2755 (patch)
tree1c167bd3cecfa253e438fefd045db110e2fa4cad /meta-systemd/meta-oe/recipes-extended/zram
parent0afa2a51d2720ed1d6c06aaef17bd90248ef650e (diff)
downloadmeta-openembedded-313f0ae25925caead4f588695ac9c9bcf00b2755.tar.gz
meta-systemd: Append ${PN} to SYSTEMD_SERVICE
When using systemd class from OE-Core we also need to install the units explicitly. systemd packages ending with -systemd are consumed and now provided by package proper. MJ: fix RPROVIDES_PN = PN-systemd in entrance MJ: add RPROVIDES for ntp*-systemd in ntp MJ: the same for wpa-supplicant Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd/meta-oe/recipes-extended/zram')
-rw-r--r--meta-systemd/meta-oe/recipes-extended/zram/zram_0.1.bbappend11
1 files changed, 9 insertions, 2 deletions
diff --git a/meta-systemd/meta-oe/recipes-extended/zram/zram_0.1.bbappend b/meta-systemd/meta-oe/recipes-extended/zram/zram_0.1.bbappend
index cc98fe1c9..34b82f72f 100644
--- a/meta-systemd/meta-oe/recipes-extended/zram/zram_0.1.bbappend
+++ b/meta-systemd/meta-oe/recipes-extended/zram/zram_0.1.bbappend
@@ -8,5 +8,12 @@ SRC_URI += " \
8 file://zram.service \ 8 file://zram.service \
9" 9"
10 10
11SYSTEMD_PACKAGES = "${PN}-systemd" 11SYSTEMD_PACKAGES = "${PN}"
12SYSTEMD_SERVICE_${PN}-systemd = "zram.service" 12RPROVIDES_${PN} += "${PN}-systemd"
13SYSTEMD_SERVICE_${PN} = "zram.service"
14
15do_install_append() {
16 install -d ${D}${systemd_unitdir}/system
17 install -m 0644 ${WORKDIR}/zram.service ${D}${systemd_unitdir}/system
18}
19