diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2012-06-10 21:46:48 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-07-16 09:39:06 +0200 |
commit | 1e6cf9483d41cf8033ada4fd15a07bb4d85aa724 (patch) | |
tree | 27ba96db0911cf7c9834b53c8982619402db83e7 /meta-systemd/meta-oe/recipes-connectivity | |
parent | ca89a235067f3328ceaa3c7a0a5bb599aaa4b428 (diff) | |
download | meta-openembedded-1e6cf9483d41cf8033ada4fd15a07bb4d85aa724.tar.gz |
dhcp: move systemd support to meta-systemd
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-systemd/meta-oe/recipes-connectivity')
3 files changed, 35 insertions, 0 deletions
diff --git a/meta-systemd/meta-oe/recipes-connectivity/dhcp/dhcp/dhcpd.service b/meta-systemd/meta-oe/recipes-connectivity/dhcp/dhcp/dhcpd.service new file mode 100644 index 000000000..70beee92e --- /dev/null +++ b/meta-systemd/meta-oe/recipes-connectivity/dhcp/dhcp/dhcpd.service | |||
@@ -0,0 +1,12 @@ | |||
1 | [Unit] | ||
2 | Description=Dynamic Host Configuration Protocol (DHCP) | ||
3 | After=syslog.target network.target | ||
4 | |||
5 | [Service] | ||
6 | Type=forking | ||
7 | PIDFile=/var/run/dhcpd.pid | ||
8 | EnvironmentFile=-/etc/default/dhcp-server | ||
9 | ExecStart=/usr/sbin/dhcpd -cf /etc/dhcp/dhcpd.conf -q $INTERFACES | ||
10 | |||
11 | [Install] | ||
12 | WantedBy=multi-user.target | ||
diff --git a/meta-systemd/meta-oe/recipes-connectivity/dhcp/dhcp/dhcrelay.service b/meta-systemd/meta-oe/recipes-connectivity/dhcp/dhcp/dhcrelay.service new file mode 100644 index 000000000..f68f468ee --- /dev/null +++ b/meta-systemd/meta-oe/recipes-connectivity/dhcp/dhcp/dhcrelay.service | |||
@@ -0,0 +1,10 @@ | |||
1 | [Unit] | ||
2 | Description=DHCP Relay Agent Daemon | ||
3 | After=syslog.target network.target | ||
4 | |||
5 | [Service] | ||
6 | EnvironmentFile=/etc/default/dhcp-relay | ||
7 | ExecStart=/usr/sbin/dhcrelay -d $DHCRELAYARGS | ||
8 | |||
9 | [Install] | ||
10 | WantedBy=multi-user.target | ||
diff --git a/meta-systemd/meta-oe/recipes-connectivity/dhcp/dhcp_4.2.3-P2.bbappend b/meta-systemd/meta-oe/recipes-connectivity/dhcp/dhcp_4.2.3-P2.bbappend new file mode 100644 index 000000000..5fd7ccb60 --- /dev/null +++ b/meta-systemd/meta-oe/recipes-connectivity/dhcp/dhcp_4.2.3-P2.bbappend | |||
@@ -0,0 +1,13 @@ | |||
1 | # look for files in the layer first | ||
2 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
3 | |||
4 | inherit systemd | ||
5 | |||
6 | PRINC := "${@int(PRINC) + 2}" | ||
7 | |||
8 | SYSTEMD_PACKAGES = "dhcp-server-systemd dhcp-relay-systemd" | ||
9 | SYSTEMD_SERVICE_dhcp-server-systemd = "dhcpd.service" | ||
10 | SYSTEMD_SERVICE_dhcp-relay-systemd = "dhcrelay.service" | ||
11 | |||
12 | SRC_URI += "file://dhcpd.service \ | ||
13 | file://dhcrelay.service" | ||