summaryrefslogtreecommitdiffstats
path: root/meta-systemd/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bbappend
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-10-31 09:08:25 -0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-11-22 16:41:21 +0000
commitc6fe627660a6085f9377337f486e11bad92082e4 (patch)
treedd1b9e6ef898982a2309e05977dc5281e1e6bc42 /meta-systemd/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bbappend
parent7da3e44c0dc53c05acce387bf5461d0e292f8d34 (diff)
downloadmeta-openembedded-c6fe627660a6085f9377337f486e11bad92082e4.tar.gz
meta-systemd: meta-networking: ntp: Update bbappend to 4.2.6p5
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'meta-systemd/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bbappend')
-rw-r--r--meta-systemd/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-systemd/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bbappend b/meta-systemd/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bbappend
new file mode 100644
index 000000000..c6cd03147
--- /dev/null
+++ b/meta-systemd/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bbappend
@@ -0,0 +1,20 @@
1inherit systemd
2
3PRINC := "${@int(PRINC) + 1}"
4
5FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
6
7SYSTEMD_PACKAGES = "${PN}-systemd ntpdate-systemd"
8SYSTEMD_SERVICE_${PN}-systemd = "ntpd.service"
9SYSTEMD_SERVICE_ntpdate-systemd = "ntpdate.service"
10
11SRC_URI += " \
12 file://ntpdate.service \
13 file://ntpd.service \
14"
15
16do_install_append() {
17 install -d ${D}${systemd_unitdir}/system
18 install -m 0644 ${WORKDIR}/ntpdate.service ${D}${systemd_unitdir}/system/
19 install -m 0644 ${WORKDIR}/ntpd.service ${D}${systemd_unitdir}/system/
20}