summaryrefslogtreecommitdiffstats
path: root/meta-systemd/meta-efl
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-02-13 17:25:35 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-12 18:49:55 +0200
commit313f0ae25925caead4f588695ac9c9bcf00b2755 (patch)
tree1c167bd3cecfa253e438fefd045db110e2fa4cad /meta-systemd/meta-efl
parent0afa2a51d2720ed1d6c06aaef17bd90248ef650e (diff)
downloadmeta-openembedded-313f0ae25925caead4f588695ac9c9bcf00b2755.tar.gz
meta-systemd: Append ${PN} to SYSTEMD_SERVICE
When using systemd class from OE-Core we also need to install the units explicitly. systemd packages ending with -systemd are consumed and now provided by package proper. MJ: fix RPROVIDES_PN = PN-systemd in entrance MJ: add RPROVIDES for ntp*-systemd in ntp MJ: the same for wpa-supplicant Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd/meta-efl')
-rw-r--r--meta-systemd/meta-efl/recipes-efl/efl/entrance_svn.bbappend16
1 files changed, 11 insertions, 5 deletions
diff --git a/meta-systemd/meta-efl/recipes-efl/efl/entrance_svn.bbappend b/meta-systemd/meta-efl/recipes-efl/efl/entrance_svn.bbappend
index df96e3495..8f85ab759 100644
--- a/meta-systemd/meta-efl/recipes-efl/efl/entrance_svn.bbappend
+++ b/meta-systemd/meta-efl/recipes-efl/efl/entrance_svn.bbappend
@@ -1,13 +1,19 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PRINC := "${@int(PRINC) + 1}" 3PRINC := "${@int(PRINC) + 2}"
4 4
5inherit systemd 5inherit systemd
6 6
7SRC_URI += "file://entrance.service" 7SRC_URI += "file://entrance.service"
8 8
9SYSTEMD_PACKAGES = "${PN}-systemd" 9RPROVIDES_${PN} += "${PN}-systemd"
10SYSTEMD_SERVICE = "entrance.service"
11 10
12RCONFLICTS_${PN}-systemd += "xserver-nodm-init-systemd" 11SYSTEMD_SERVICE_${PN} = "entrance.service"
13RREPLACES_${PN}-systemd += "xserver-nodm-init-systemd" 12
13do_install_append() {
14 install -d ${D}${systemd_unitdir}/system
15 install -m 0644 ${WORKDIR}/entrance.service ${D}${systemd_unitdir}/system
16}
17
18RCONFLICTS_${PN} += "xserver-nodm-init-systemd"
19RREPLACES_${PN} += "xserver-nodm-init-systemd"