summaryrefslogtreecommitdiffstats
path: root/meta-ruby
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-06-24 07:44:04 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-06-29 14:22:46 +0200
commit370e7d2b7dad956421a288c94c874501984f3bc4 (patch)
tree7094cc97247adf6bfb0cd69a61d6e82a4043de67 /meta-ruby
parent41e0bcf188c457548a37e32fe291a848d8e10005 (diff)
downloadmeta-openembedded-370e7d2b7dad956421a288c94c874501984f3bc4.tar.gz
ruby: Upgrade from 1.9.3-p194 -> 1.9.3-p429
Old recipe was having do_install failures this fixes those too Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-ruby')
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby.inc2
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby/ruby-1.9.3-bignum-test-fix.patch31
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby/ruby-1.9.3-webrick-test-fix.patch24
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb (renamed from meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p194.bb)7
4 files changed, 3 insertions, 61 deletions
diff --git a/meta-ruby/recipes-devtools/ruby/ruby.inc b/meta-ruby/recipes-devtools/ruby/ruby.inc
index becf64c93..18fcb9c7b 100644
--- a/meta-ruby/recipes-devtools/ruby/ruby.inc
+++ b/meta-ruby/recipes-devtools/ruby/ruby.inc
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "\
11 file://COPYING;md5=837b32593517ae48b9c3b5c87a5d288c \ 11 file://COPYING;md5=837b32593517ae48b9c3b5c87a5d288c \
12 file://BSDL;md5=3949e007205deef714bd225e1ee4a8ea \ 12 file://BSDL;md5=3949e007205deef714bd225e1ee4a8ea \
13 file://GPL;md5=393a5ca445f6965873eca0259a17f833 \ 13 file://GPL;md5=393a5ca445f6965873eca0259a17f833 \
14 file://LEGAL;md5=e88686821918c0b6d2b1b8328116cec5 \ 14 file://LEGAL;md5=3ce1fae39fe573b818c0af162bce6579 \
15" 15"
16 16
17DEPENDS = "ruby-native zlib openssl tcl" 17DEPENDS = "ruby-native zlib openssl tcl"
diff --git a/meta-ruby/recipes-devtools/ruby/ruby/ruby-1.9.3-bignum-test-fix.patch b/meta-ruby/recipes-devtools/ruby/ruby/ruby-1.9.3-bignum-test-fix.patch
deleted file mode 100644
index cb3682d5e..000000000
--- a/meta-ruby/recipes-devtools/ruby/ruby/ruby-1.9.3-bignum-test-fix.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1--- ruby-1.9.3-p0/test/ruby/test_bignum.rb.orig 2011-11-10 09:52:59.101925465 +0100
2+++ ruby-1.9.3-p0/test/ruby/test_bignum.rb 2011-11-10 09:54:14.580798826 +0100
3@@ -378,7 +378,7 @@
4 assert_equal(true, (2**32).even?)
5 end
6
7- def interrupt
8+ def assert_interrupt
9 time = Time.now
10 start_flag = false
11 end_flag = false
12@@ -387,14 +387,16 @@
13 yield
14 end_flag = true
15 end
16- sleep 1
17+ Thread.pass until start_flag
18 thread.raise
19 thread.join rescue nil
20- start_flag && !end_flag && Time.now - time < 10
21+ time = Time.now - time
22+ assert_equal([true, false], [start_flag, end_flag])
23+ assert_operator(time, :<, 10)
24 end
25
26 def test_interrupt
27- assert(interrupt { (65536 ** 65536).to_s })
28+ assert_interrupt {(65536 ** 65536).to_s}
29 end
30
31 def test_too_big_to_s
diff --git a/meta-ruby/recipes-devtools/ruby/ruby/ruby-1.9.3-webrick-test-fix.patch b/meta-ruby/recipes-devtools/ruby/ruby/ruby-1.9.3-webrick-test-fix.patch
deleted file mode 100644
index c6eb3fa40..000000000
--- a/meta-ruby/recipes-devtools/ruby/ruby/ruby-1.9.3-webrick-test-fix.patch
+++ /dev/null
@@ -1,24 +0,0 @@
1diff --git a/test/webrick/test_cgi.rb b/test/webrick/test_cgi.rb
2index 1185316..0ef1b37 100644
3--- a/test/webrick/test_cgi.rb
4+++ b/test/webrick/test_cgi.rb
5@@ -14,6 +14,7 @@ class TestWEBrickCGI < Test::Unit::TestCase
6 def req.meta_vars
7 meta = super
8 meta["RUBYLIB"] = $:.join(File::PATH_SEPARATOR)
9+ meta[RbConfig::CONFIG['LIBPATHENV']] = ENV[RbConfig::CONFIG['LIBPATHENV']]
10 return meta
11 end
12 },
13diff --git a/test/webrick/test_filehandler.rb b/test/webrick/test_filehandler.rb
14index bcdb3df..f78ba5c 100644
15--- a/test/webrick/test_filehandler.rb
16+++ b/test/webrick/test_filehandler.rb
17@@ -252,6 +252,7 @@ class WEBrick::TestFileHandler < Test::Unit::TestCase
18 def req.meta_vars
19 meta = super
20 meta["RUBYLIB"] = $:.join(File::PATH_SEPARATOR)
21+ meta[RbConfig::CONFIG['LIBPATHENV']] = ENV[RbConfig::CONFIG['LIBPATHENV']]
22 return meta
23 end
24 },
diff --git a/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p194.bb b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb
index 6611ce11e..7c5be3664 100644
--- a/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p194.bb
+++ b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb
@@ -9,16 +9,13 @@ SRC_URI += "\
9 file://ruby-1.9.3-disable-versioned-paths.patch \ 9 file://ruby-1.9.3-disable-versioned-paths.patch \
10 file://ruby-1.9.3-fix-s390x-build.patch \ 10 file://ruby-1.9.3-fix-s390x-build.patch \
11 file://ruby-1.9.3-rubygems-1.8.11-uninstaller.patch \ 11 file://ruby-1.9.3-rubygems-1.8.11-uninstaller.patch \
12 file://ruby-1.9.3-webrick-test-fix.patch \
13 file://ruby-1.9.3-bignum-test-fix.patch \
14 file://ruby-1.9.3-custom-rubygems-location.patch \ 12 file://ruby-1.9.3-custom-rubygems-location.patch \
15 file://rubygems-1.8.11-binary-extensions.patch \ 13 file://rubygems-1.8.11-binary-extensions.patch \
16 file://ruby-1.9.3-mkmf-verbose.patch \ 14 file://ruby-1.9.3-mkmf-verbose.patch \
17 file://ruby-1.9.3-install-cross.patch \ 15 file://ruby-1.9.3-install-cross.patch \
18" 16"
19 17SRC_URI[md5sum] = "993c72f7f805a9eb453f90b0b7fe0d2b"
20SRC_URI[md5sum] = "bc0c715c69da4d1d8bd57069c19f6c0e" 18SRC_URI[sha256sum] = "d192d1afc46a7ef27b9d0a3c7a67b509048984db2c38907aa82641bdf980acf4"
21SRC_URI[sha256sum] = "46e2fa80be7efed51bd9cdc529d1fe22ebc7567ee0f91db4ab855438cf4bd8bb"
22 19
23EXTRA_OECONF = "\ 20EXTRA_OECONF = "\
24 --enable-wide-getaddrinfo \ 21 --enable-wide-getaddrinfo \