summaryrefslogtreecommitdiffstats
path: root/meta-ruby
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-ruby
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-ruby')
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby.inc12
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p194.bb44
2 files changed, 28 insertions, 28 deletions
diff --git a/meta-ruby/recipes-devtools/ruby/ruby.inc b/meta-ruby/recipes-devtools/ruby/ruby.inc
index 894e3e6a9..becf64c93 100644
--- a/meta-ruby/recipes-devtools/ruby/ruby.inc
+++ b/meta-ruby/recipes-devtools/ruby/ruby.inc
@@ -8,10 +8,10 @@ HOMEPAGE = "http://www.ruby-lang.org/"
8SECTION = "devel/ruby" 8SECTION = "devel/ruby"
9LICENSE = "Ruby | BSD | GPLv2" 9LICENSE = "Ruby | BSD | GPLv2"
10LIC_FILES_CHKSUM = "\ 10LIC_FILES_CHKSUM = "\
11 file://COPYING;md5=837b32593517ae48b9c3b5c87a5d288c \ 11 file://COPYING;md5=837b32593517ae48b9c3b5c87a5d288c \
12 file://BSDL;md5=3949e007205deef714bd225e1ee4a8ea \ 12 file://BSDL;md5=3949e007205deef714bd225e1ee4a8ea \
13 file://GPL;md5=393a5ca445f6965873eca0259a17f833 \ 13 file://GPL;md5=393a5ca445f6965873eca0259a17f833 \
14 file://LEGAL;md5=e88686821918c0b6d2b1b8328116cec5 \ 14 file://LEGAL;md5=e88686821918c0b6d2b1b8328116cec5 \
15" 15"
16 16
17DEPENDS = "ruby-native zlib openssl tcl" 17DEPENDS = "ruby-native zlib openssl tcl"
@@ -38,6 +38,6 @@ inherit autotools
38# built. 38# built.
39 39
40do_configure_prepend() { 40do_configure_prepend() {
41 sed -i "s#%%TARGET_CFLAGS%%#$TARGET_CFLAGS#; s#%%TARGET_LDFLAGS%%#$TARGET_LDFLAGS#" ${S}/common.mk 41 sed -i "s#%%TARGET_CFLAGS%%#$TARGET_CFLAGS#; s#%%TARGET_LDFLAGS%%#$TARGET_LDFLAGS#" ${S}/common.mk
42 rm -rf ${S}/ruby/ 42 rm -rf ${S}/ruby/
43} 43}
diff --git a/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p194.bb b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p194.bb
index b9f7915d9..6611ce11e 100644
--- a/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p194.bb
+++ b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p194.bb
@@ -4,40 +4,40 @@ PR = "${INC_PR}.0"
4DEPENDS += "libyaml" 4DEPENDS += "libyaml"
5 5
6SRC_URI += "\ 6SRC_URI += "\
7 file://0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch \ 7 file://0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch \
8 file://ruby-1.9.3-always-use-i386.patch \ 8 file://ruby-1.9.3-always-use-i386.patch \
9 file://ruby-1.9.3-disable-versioned-paths.patch \ 9 file://ruby-1.9.3-disable-versioned-paths.patch \
10 file://ruby-1.9.3-fix-s390x-build.patch \ 10 file://ruby-1.9.3-fix-s390x-build.patch \
11 file://ruby-1.9.3-rubygems-1.8.11-uninstaller.patch \ 11 file://ruby-1.9.3-rubygems-1.8.11-uninstaller.patch \
12 file://ruby-1.9.3-webrick-test-fix.patch \ 12 file://ruby-1.9.3-webrick-test-fix.patch \
13 file://ruby-1.9.3-bignum-test-fix.patch \ 13 file://ruby-1.9.3-bignum-test-fix.patch \
14 file://ruby-1.9.3-custom-rubygems-location.patch \ 14 file://ruby-1.9.3-custom-rubygems-location.patch \
15 file://rubygems-1.8.11-binary-extensions.patch \ 15 file://rubygems-1.8.11-binary-extensions.patch \
16 file://ruby-1.9.3-mkmf-verbose.patch \ 16 file://ruby-1.9.3-mkmf-verbose.patch \
17 file://ruby-1.9.3-install-cross.patch \ 17 file://ruby-1.9.3-install-cross.patch \
18" 18"
19 19
20SRC_URI[md5sum] = "bc0c715c69da4d1d8bd57069c19f6c0e" 20SRC_URI[md5sum] = "bc0c715c69da4d1d8bd57069c19f6c0e"
21SRC_URI[sha256sum] = "46e2fa80be7efed51bd9cdc529d1fe22ebc7567ee0f91db4ab855438cf4bd8bb" 21SRC_URI[sha256sum] = "46e2fa80be7efed51bd9cdc529d1fe22ebc7567ee0f91db4ab855438cf4bd8bb"
22 22
23EXTRA_OECONF = "\ 23EXTRA_OECONF = "\
24 --enable-wide-getaddrinfo \ 24 --enable-wide-getaddrinfo \
25 --with-rubygemsdir=${datadir}/rubygems \ 25 --with-rubygemsdir=${datadir}/rubygems \
26 --disable-versioned-paths \ 26 --disable-versioned-paths \
27 --disable-rpath \ 27 --disable-rpath \
28 --enable-shared \ 28 --enable-shared \
29" 29"
30 30
31EXTRA_OEMAKE = " \ 31EXTRA_OEMAKE = " \
32 LIBRUBYARG='-lruby-static' \ 32 LIBRUBYARG='-lruby-static' \
33" 33"
34 34
35do_install() { 35do_install() {
36 if [ ${PN} = "ruby" ]; then 36 if [ ${PN} = "ruby" ]; then
37 oe_runmake 'DESTDIR=${D}' install install-cross 37 oe_runmake 'DESTDIR=${D}' install install-cross
38 else 38 else
39 oe_runmake 'DESTDIR=${D}' install 39 oe_runmake 'DESTDIR=${D}' install
40 fi 40 fi
41} 41}
42 42
43FILES_${PN} += "${datadir}/rubygems \ 43FILES_${PN} += "${datadir}/rubygems \