diff options
author | Jackie Huang <jackie.huang@windriver.com> | 2012-10-16 08:34:41 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2012-12-26 14:09:56 +0100 |
commit | d04b996ec223465729920ec3599b53dabb3ceb05 (patch) | |
tree | c4d82d0bbaa01bd41e934a2177803d87b3778d18 /meta-ruby/recipes-devtools | |
parent | a1e6087f092e09d85928440ba86857061abcc65b (diff) | |
download | meta-openembedded-d04b996ec223465729920ec3599b53dabb3ceb05.tar.gz |
ruby: Add from OE-Classic
* No modifications in this commit
* MJ: PR reset, PRIORITY dropped, LICENSE fix, LIC_FILES_CHKSUMs added
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-ruby/recipes-devtools')
5 files changed, 109 insertions, 0 deletions
diff --git a/meta-ruby/recipes-devtools/ruby/ruby.inc b/meta-ruby/recipes-devtools/ruby/ruby.inc new file mode 100644 index 000000000..a70f95151 --- /dev/null +++ b/meta-ruby/recipes-devtools/ruby/ruby.inc | |||
@@ -0,0 +1,38 @@ | |||
1 | DESCRIPTION = "Ruby is an interpreted scripting language \ | ||
2 | for quick and easy object-oriented programming." | ||
3 | SECTION = "devel/ruby" | ||
4 | LICENSE = "GPLv2 & LGPLv2+ & BSD" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=99f88e67b65504d289a0326c59f9c148 \ | ||
6 | file://LEGAL;md5=7d502ae3b621dc406b220dadddb72e16 \ | ||
7 | file://LGPL;md5=7fbc338309ac38fefcd64b04bb903e34 \ | ||
8 | " | ||
9 | |||
10 | DEPENDS = "ruby-native zlib openssl" | ||
11 | DEPENDS_virtclass-native = "" | ||
12 | |||
13 | INC_PR = "r0" | ||
14 | |||
15 | SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}" | ||
16 | SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/${SHRT_VER}/ruby-${PV}.tar.gz \ | ||
17 | file://extmk_run.patch \ | ||
18 | file://extmk.patch \ | ||
19 | " | ||
20 | |||
21 | S = "${WORKDIR}/ruby-${PV}" | ||
22 | |||
23 | inherit autotools | ||
24 | |||
25 | # fix building of socket extension | ||
26 | EXTRA_OECONF = "--enable-wide-getaddrinfo" | ||
27 | |||
28 | # This snippet lets compiled extensions which rely on external libraries, | ||
29 | # such as zlib, compile properly. If we don't do this, then when extmk.rb | ||
30 | # runs, it uses the native libraries instead of the target libraries, and so | ||
31 | # none of the linking operations succeed -- which makes extconf.rb think | ||
32 | # that the libraries aren't available and hence that the extension can't be | ||
33 | # built. | ||
34 | |||
35 | do_configure_prepend() { | ||
36 | sed -i "s#%%TARGET_CFLAGS%%#$TARGET_CFLAGS#; s#%%TARGET_LDFLAGS%%#$TARGET_LDFLAGS#" ${S}/common.mk | ||
37 | rm -rf ${S}/ruby/ | ||
38 | } | ||
diff --git a/meta-ruby/recipes-devtools/ruby/ruby/0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch b/meta-ruby/recipes-devtools/ruby/ruby/0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch new file mode 100644 index 000000000..64f093a4f --- /dev/null +++ b/meta-ruby/recipes-devtools/ruby/ruby/0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 9341293e71c03fe606edc9157bf1e13e3dd5b507 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Fri, 17 Dec 2010 11:35:38 +0100 | ||
4 | Subject: [PATCH] socket extconf: hardcode wide-getaddr info test outcome to true | ||
5 | |||
6 | Without this the socket extension doesn't build correctly | ||
7 | |||
8 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
9 | --- | ||
10 | ext/socket/extconf.rb | 5 +++++ | ||
11 | 1 files changed, 5 insertions(+), 0 deletions(-) | ||
12 | |||
13 | diff --git a/ext/socket/extconf.rb b/ext/socket/extconf.rb | ||
14 | index ece6158..5fba46c 100644 | ||
15 | --- a/ext/socket/extconf.rb | ||
16 | +++ b/ext/socket/extconf.rb | ||
17 | @@ -222,6 +222,11 @@ main() | ||
18 | exit(EXIT_FAILURE); | ||
19 | } | ||
20 | EOF | ||
21 | + | ||
22 | +# Ignore the actual result of the above test and assume that | ||
23 | +# everything is OK. | ||
24 | +getaddr_info_ok = true | ||
25 | + | ||
26 | end | ||
27 | if ipv6 and not getaddr_info_ok | ||
28 | abort <<EOS | ||
29 | -- | ||
30 | 1.6.6.1 | ||
31 | |||
diff --git a/meta-ruby/recipes-devtools/ruby/ruby/extmk.patch b/meta-ruby/recipes-devtools/ruby/ruby/extmk.patch new file mode 100644 index 000000000..8b6845034 --- /dev/null +++ b/meta-ruby/recipes-devtools/ruby/ruby/extmk.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | diff -ru ruby-1.8.7-p248.orig/ext/extmk.rb ruby-1.8.7-p248/ext/extmk.rb | ||
2 | --- ruby-1.8.7-p248.orig/ext/extmk.rb 2009-12-24 03:01:58.000000000 -0600 | ||
3 | +++ ruby-1.8.7-p248/ext/extmk.rb 2010-02-12 15:55:27.370061558 -0600 | ||
4 | @@ -354,8 +354,8 @@ | ||
5 | $ruby = '$(topdir)/miniruby' + EXEEXT | ||
6 | end | ||
7 | $ruby << " -I'$(topdir)'" | ||
8 | +$ruby << " -I'$(top_srcdir)/lib'" | ||
9 | unless CROSS_COMPILING | ||
10 | - $ruby << " -I'$(top_srcdir)/lib'" | ||
11 | $ruby << " -I'$(extout)/$(arch)' -I'$(extout)/common'" if $extout | ||
12 | $ruby << " -I./- -I'$(top_srcdir)/ext' -rpurelib.rb" | ||
13 | ENV["RUBYLIB"] = "-" | ||
diff --git a/meta-ruby/recipes-devtools/ruby/ruby/extmk_run.patch b/meta-ruby/recipes-devtools/ruby/ruby/extmk_run.patch new file mode 100644 index 000000000..57926f51b --- /dev/null +++ b/meta-ruby/recipes-devtools/ruby/ruby/extmk_run.patch | |||
@@ -0,0 +1,15 @@ | |||
1 | ============================================================ | ||
2 | --- packages/ruby/ruby-1.8.5/extmk_run.patch d9738b5a71e2f9a98d009af9fd0ef1ceaff9ef48 | ||
3 | +++ packages/ruby/ruby-1.8.5/extmk_run.patch d9738b5a71e2f9a98d009af9fd0ef1ceaff9ef48 | ||
4 | @@ -0,0 +1,11 @@ | ||
5 | +--- ruby-1.8.5/common.mk.orig 2006-12-30 13:07:32.000000000 +1100 | ||
6 | ++++ ruby-1.8.5/common.mk 2006-12-30 13:08:32.000000000 +1100 | ||
7 | +@@ -56,7 +56,7 @@ | ||
8 | + --make="$(MAKE)" \ | ||
9 | + --mflags="$(MFLAGS)" \ | ||
10 | + --make-flags="$(MAKEFLAGS)" | ||
11 | +-EXTMK_ARGS = $(SCRIPT_ARGS) --extout="$(EXTOUT)" --extension $(EXTS) --extstatic $(EXTSTATIC) -- | ||
12 | ++EXTMK_ARGS = $(SCRIPT_ARGS) --with-ldflags="%%TARGET_LDFLAGS%%" --with-cflags="%%TARGET_CFLAGS%%" --extout="$(EXTOUT)" --extension $(EXTS) --extstatic $(EXTSTATIC) -- | ||
13 | + | ||
14 | + all: $(MKFILES) $(PREP) $(RBCONFIG) $(LIBRUBY) | ||
15 | + @$(MINIRUBY) $(srcdir)/ext/extmk.rb $(EXTMK_ARGS) | ||
diff --git a/meta-ruby/recipes-devtools/ruby/ruby_1.8.7-p302.bb b/meta-ruby/recipes-devtools/ruby/ruby_1.8.7-p302.bb new file mode 100644 index 000000000..299187ca6 --- /dev/null +++ b/meta-ruby/recipes-devtools/ruby/ruby_1.8.7-p302.bb | |||
@@ -0,0 +1,12 @@ | |||
1 | require ruby.inc | ||
2 | PR = "${INC_PR}.0" | ||
3 | |||
4 | SRC_URI += "file://0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch" | ||
5 | |||
6 | SRC_URI[md5sum] = "f446550dfde0d8162a6ed8d5a38b3ac2" | ||
7 | SRC_URI[sha256sum] = "5883df5204de70762602ce885b18c8bf6c856d33298c35df9151031b2ce044a1" | ||
8 | |||
9 | FILES_${PN}-dbg += "${libdir}/ruby/1.8/*/.debug \ | ||
10 | ${libdir}/ruby/1.8/*/*/.debug" | ||
11 | BBCLASSEXTEND = "native" | ||
12 | |||