diff options
author | Roy Li <rongqing.li@windriver.com> | 2014-08-06 14:44:27 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-08-10 16:07:19 +0200 |
commit | 7815a6d97ec81487ebcd18e39558241959c9a96b (patch) | |
tree | 6b874ce4e60bfc8e22c3537fb044bd96675a7d82 /meta-ruby/recipes-devtools | |
parent | e0e1f8d24447098d4c2652cea1930edd36616c91 (diff) | |
download | meta-openembedded-7815a6d97ec81487ebcd18e39558241959c9a96b.tar.gz |
ruby: fix a parallel building issue
Signed-off-by: Roy Li <rongqing.li@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-ruby/recipes-devtools')
-rw-r--r-- | meta-ruby/recipes-devtools/ruby/ruby/remove-the-dependency-on-dir.patch | 37 | ||||
-rw-r--r-- | meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p547.bb | 1 |
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-ruby/recipes-devtools/ruby/ruby/remove-the-dependency-on-dir.patch b/meta-ruby/recipes-devtools/ruby/ruby/remove-the-dependency-on-dir.patch new file mode 100644 index 000000000..a4ac3eacc --- /dev/null +++ b/meta-ruby/recipes-devtools/ruby/ruby/remove-the-dependency-on-dir.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | remove a duplicate dependency | ||
2 | |||
3 | Upstream-status: Pending | ||
4 | |||
5 | The install-rb-default dependency is as below: | ||
6 | |||
7 | pre-install-rb-default: | ||
8 | mkdir -p $(RUBYLIBDIR)/bigdecimal | ||
9 | |||
10 | install-rb-default: pre-install-rb-default $(RUBYLIBDIR)/bigdecimal | ||
11 | |||
12 | In fact, dependency on $(RUBYLIBDIR)/bigdecimal is duplicate, and not rule | ||
13 | for $(RUBYLIBDIR)/bigdecimal, once $(RUBYLIBDIR)/bigdecimal is checked before | ||
14 | pre-install-rb-default, the below error will happen | ||
15 | *** No rule to make target `../../.ext/common/yaml', needed by `install-rb-default'. Stop | ||
16 | |||
17 | Signed-off-by: Roy Li <rongqing.li@windriver.com> | ||
18 | --- | ||
19 | lib/mkmf.rb | 2 +- | ||
20 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
21 | |||
22 | diff --git a/lib/mkmf.rb b/lib/mkmf.rb | ||
23 | index 1f5ed76..556684c 100644 | ||
24 | --- a/lib/mkmf.rb | ||
25 | +++ b/lib/mkmf.rb | ||
26 | @@ -2054,7 +2054,7 @@ static: $(STATIC_LIB)#{$extout ? " install-rb" : ""} | ||
27 | end | ||
28 | for f in files | ||
29 | dest = "#{dir}/#{File.basename(f)}" | ||
30 | - mfile.print("install-rb#{sfx}: #{dest} #{dir}\n") | ||
31 | + mfile.print("install-rb#{sfx}: #{dest}\n") | ||
32 | mfile.print("#{dest}: #{f}\n") | ||
33 | mfile.print("\t$(Q) $(#{$extout ? 'COPY' : 'INSTALL_DATA'}) #{f} $(@D#{sep})\n") | ||
34 | if defined?($installed_list) and !$extout | ||
35 | -- | ||
36 | 1.7.10.4 | ||
37 | |||
diff --git a/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p547.bb b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p547.bb index 2404a5fda..24bacdc4c 100644 --- a/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p547.bb +++ b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p547.bb | |||
@@ -10,6 +10,7 @@ SRC_URI += "\ | |||
10 | file://rubygems-1.8.11-binary-extensions.patch \ | 10 | file://rubygems-1.8.11-binary-extensions.patch \ |
11 | file://ruby-1.9.3-mkmf-verbose.patch \ | 11 | file://ruby-1.9.3-mkmf-verbose.patch \ |
12 | file://ruby-1.9.3-install-cross.patch \ | 12 | file://ruby-1.9.3-install-cross.patch \ |
13 | file://remove-the-dependency-on-dir.patch \ | ||
13 | " | 14 | " |
14 | SRC_URI[md5sum] = "7531f9b1b35b16f3eb3d7bea786babfd" | 15 | SRC_URI[md5sum] = "7531f9b1b35b16f3eb3d7bea786babfd" |
15 | SRC_URI[sha256sum] = "9ba118e4aba04c430bc4d5efb09b31a0277e101c9fd2ef3b80b9c684d7ae57a1" | 16 | SRC_URI[sha256sum] = "9ba118e4aba04c430bc4d5efb09b31a0277e101c9fd2ef3b80b9c684d7ae57a1" |