summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2019-01-29 13:12:40 +0100
committerKhem Raj <raj.khem@gmail.com>2019-01-30 13:34:49 -0800
commitee93134f9f52f7817cb1ffcf18bc03ba89e5f823 (patch)
treefb7ed9214d3508c4f33aa70fdc7c578650f8a87b /meta-python
parentbd6803523cf5d831e08d2a30c018828c0266af1a (diff)
downloadmeta-openembedded-ee93134f9f52f7817cb1ffcf18bc03ba89e5f823.tar.gz
python-vcversioner: remove egg generation
Remove egg file build. This got introduced with commit fb1696372ff9 ("python-vcversioner: Error Fix for recipes depend on python-vcversioner"). However, it seems that this was actually not related to the missing egg file, but to the back then missing depends on python-vcversioner-native. This got fixed in commit 12d09665bbee ("python-jsonschema, python3-jsonschema: add vcversioner-native dependency"). It also causes issue when trying to build a reproducible build with a timestamp of 0 due to limitations of the ZIP file format used by the Python egg packaging. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-vcversioner_2.16.0.0.bb8
1 files changed, 0 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python-vcversioner_2.16.0.0.bb b/meta-python/recipes-devtools/python/python-vcversioner_2.16.0.0.bb
index cd6fa8dff..e6cc4acce 100644
--- a/meta-python/recipes-devtools/python/python-vcversioner_2.16.0.0.bb
+++ b/meta-python/recipes-devtools/python/python-vcversioner_2.16.0.0.bb
@@ -9,14 +9,6 @@ SRC_URI[sha256sum] = "dae60c17a479781f44a4010701833f1829140b1eeccd258762a74974aa
9 9
10inherit pypi setuptools 10inherit pypi setuptools
11 11
12do_compile_append() {
13 ${PYTHON} setup.py -q bdist_egg --dist-dir ./
14}
15
16do_install_append() {
17 install -m 0644 ${S}/vcversioner*.egg ${D}/${PYTHON_SITEPACKAGES_DIR}/
18}
19
20RDEPENDS_${PN} += "\ 12RDEPENDS_${PN} += "\
21 ${PYTHON_PN}-subprocess \ 13 ${PYTHON_PN}-subprocess \
22 " 14 "