summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-21 11:20:32 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-26 17:28:11 -0800
commit79080374c81fdcf404db9bc24e4a0b1455042fee (patch)
treeb2e29779faa42117d6f5a8c2b85e734d74b14ac5 /meta-python
parent90b1f996af78504a6ea233d6db976a9752981511 (diff)
downloadmeta-openembedded-79080374c81fdcf404db9bc24e4a0b1455042fee.tar.gz
Remove deprecated ${PYTHON_PN}-importlib from the RDEPENDS
The ${PYTHON_PN}-importlib package was removed as part of the migration to the json manifest file. The functionality is now part of core Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-astroid_1.6.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python-behave_1.2.5.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-can.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-dbusmock_0.16.7.bb1
-rw-r--r--meta-python/recipes-devtools/python/python-django.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-pandas_0.22.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python-pyroute2.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-pyserial_3.4.bb2
8 files changed, 2 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python-astroid_1.6.0.bb b/meta-python/recipes-devtools/python/python-astroid_1.6.0.bb
index 42208bcb1..fd98630e1 100644
--- a/meta-python/recipes-devtools/python/python-astroid_1.6.0.bb
+++ b/meta-python/recipes-devtools/python/python-astroid_1.6.0.bb
@@ -4,7 +4,6 @@ require python-astroid.inc
4RDEPENDS_${PN}_class-target += " \ 4RDEPENDS_${PN}_class-target += " \
5 ${PYTHON_PN}-enum34 \ 5 ${PYTHON_PN}-enum34 \
6 ${PYTHON_PN}-backports-functools-lru-cache \ 6 ${PYTHON_PN}-backports-functools-lru-cache \
7 ${PYTHON_PN}-importlib \
8 ${PYTHON_PN}-re \ 7 ${PYTHON_PN}-re \
9 ${PYTHON_PN}-singledispatch \ 8 ${PYTHON_PN}-singledispatch \
10" 9"
diff --git a/meta-python/recipes-devtools/python/python-behave_1.2.5.bb b/meta-python/recipes-devtools/python/python-behave_1.2.5.bb
index 541a79d7b..3db2016eb 100644
--- a/meta-python/recipes-devtools/python/python-behave_1.2.5.bb
+++ b/meta-python/recipes-devtools/python/python-behave_1.2.5.bb
@@ -5,6 +5,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=d950439e8ea6ed233e4288f5e1a49c06"
5SRC_URI[md5sum] = "3af4bc2886d2be982e41bfaba61da3bc" 5SRC_URI[md5sum] = "3af4bc2886d2be982e41bfaba61da3bc"
6SRC_URI[sha256sum] = "81b731ac5187e31e4aad2594944fa914943683a9818320846d037c5ebd6d5d0b" 6SRC_URI[sha256sum] = "81b731ac5187e31e4aad2594944fa914943683a9818320846d037c5ebd6d5d0b"
7 7
8RDEPENDS_${PN} += "python-difflib python-setuptools python-pkgutil python-misc python-argparse python-xml python-importlib python-enum34 python-parse python-parse-type python-six" 8RDEPENDS_${PN} += "python-difflib python-setuptools python-pkgutil python-misc python-argparse python-xml python-enum34 python-parse python-parse-type python-six"
9 9
10inherit pypi setuptools 10inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python-can.inc b/meta-python/recipes-devtools/python/python-can.inc
index 8cdd4d38f..2b15af40a 100644
--- a/meta-python/recipes-devtools/python/python-can.inc
+++ b/meta-python/recipes-devtools/python/python-can.inc
@@ -10,7 +10,6 @@ PYPI_PACKAGE="python-can"
10 10
11RDEPENDS_${PN}_class-target += "\ 11RDEPENDS_${PN}_class-target += "\
12 ${PYTHON_PN}-ctypes \ 12 ${PYTHON_PN}-ctypes \
13 ${PYTHON_PN}-importlib \
14 ${PYTHON_PN}-logging \ 13 ${PYTHON_PN}-logging \
15 ${PYTHON_PN}-misc \ 14 ${PYTHON_PN}-misc \
16 ${PYTHON_PN}-netserver \ 15 ${PYTHON_PN}-netserver \
diff --git a/meta-python/recipes-devtools/python/python-dbusmock_0.16.7.bb b/meta-python/recipes-devtools/python/python-dbusmock_0.16.7.bb
index fb8c0aa60..ec8c54aac 100644
--- a/meta-python/recipes-devtools/python/python-dbusmock_0.16.7.bb
+++ b/meta-python/recipes-devtools/python/python-dbusmock_0.16.7.bb
@@ -20,7 +20,6 @@ inherit pypi setuptools
20 20
21RDEPENDS_${PN} += "\ 21RDEPENDS_${PN} += "\
22 ${PYTHON_PN}-dbus \ 22 ${PYTHON_PN}-dbus \
23 ${PYTHON_PN}-importlib \
24 ${PYTHON_PN}-pygobject \ 23 ${PYTHON_PN}-pygobject \
25 ${PYTHON_PN}-xml \ 24 ${PYTHON_PN}-xml \
26 " 25 "
diff --git a/meta-python/recipes-devtools/python/python-django.inc b/meta-python/recipes-devtools/python/python-django.inc
index 9287715ea..3602a74aa 100644
--- a/meta-python/recipes-devtools/python/python-django.inc
+++ b/meta-python/recipes-devtools/python/python-django.inc
@@ -19,7 +19,6 @@ RDEPENDS_${PN} += "\
19 ${PYTHON_PN}-datetime \ 19 ${PYTHON_PN}-datetime \
20 ${PYTHON_PN}-email \ 20 ${PYTHON_PN}-email \
21 ${PYTHON_PN}-html \ 21 ${PYTHON_PN}-html \
22 ${PYTHON_PN}-importlib \
23 ${PYTHON_PN}-json \ 22 ${PYTHON_PN}-json \
24 ${PYTHON_PN}-multiprocessing \ 23 ${PYTHON_PN}-multiprocessing \
25 ${PYTHON_PN}-netserver \ 24 ${PYTHON_PN}-netserver \
diff --git a/meta-python/recipes-devtools/python/python-pandas_0.22.0.bb b/meta-python/recipes-devtools/python/python-pandas_0.22.0.bb
index 355074cb2..b3bfab969 100644
--- a/meta-python/recipes-devtools/python/python-pandas_0.22.0.bb
+++ b/meta-python/recipes-devtools/python/python-pandas_0.22.0.bb
@@ -4,5 +4,4 @@ require python-pandas.inc
4RDEPENDS_${PN} += " \ 4RDEPENDS_${PN} += " \
5 ${PYTHON_PN}-future \ 5 ${PYTHON_PN}-future \
6 ${PYTHON_PN}-json \ 6 ${PYTHON_PN}-json \
7 ${PYTHON_PN}-importlib \
8" 7"
diff --git a/meta-python/recipes-devtools/python/python-pyroute2.inc b/meta-python/recipes-devtools/python/python-pyroute2.inc
index f63ccbd66..24e3555c7 100644
--- a/meta-python/recipes-devtools/python/python-pyroute2.inc
+++ b/meta-python/recipes-devtools/python/python-pyroute2.inc
@@ -13,7 +13,6 @@ inherit pypi
13RDEPENDS_${PN} += " \ 13RDEPENDS_${PN} += " \
14 ${PYTHON_PN}-ctypes \ 14 ${PYTHON_PN}-ctypes \
15 ${PYTHON_PN}-distutils \ 15 ${PYTHON_PN}-distutils \
16 ${PYTHON_PN}-importlib \
17 ${PYTHON_PN}-json \ 16 ${PYTHON_PN}-json \
18 ${PYTHON_PN}-logging \ 17 ${PYTHON_PN}-logging \
19 ${PYTHON_PN}-multiprocessing \ 18 ${PYTHON_PN}-multiprocessing \
diff --git a/meta-python/recipes-devtools/python/python-pyserial_3.4.bb b/meta-python/recipes-devtools/python/python-pyserial_3.4.bb
index 0497087ac..fd852a2bf 100644
--- a/meta-python/recipes-devtools/python/python-pyserial_3.4.bb
+++ b/meta-python/recipes-devtools/python/python-pyserial_3.4.bb
@@ -1,4 +1,4 @@
1inherit setuptools 1inherit setuptools
2require python-pyserial.inc 2require python-pyserial.inc
3 3
4RDEPENDS_${PN} += "${PYTHON_PN}-argparse ${PYTHON_PN}-importlib" 4RDEPENDS_${PN} += "${PYTHON_PN}-argparse"