summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2019-09-30 13:11:20 +0800
committerKhem Raj <raj.khem@gmail.com>2019-09-30 16:54:51 -0700
commit783c4ea997243bb1266a801e0eb317bde908dcf3 (patch)
tree27efcb222d19398a79dbc1ae2e49b208b6677570 /meta-python
parent233d3b20c5892f34ce4949fcf9bb5d9bcde11d56 (diff)
downloadmeta-openembedded-783c4ea997243bb1266a801e0eb317bde908dcf3.tar.gz
python-pycurl: add recipes for python2 and python3
PycURL is a Python interface to libcurl, the multiprotocol file transfer library. Similarly to the urllib Python module, PycURL can be used to fetch objects identified by a URL from a Python program Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pycurl.inc26
-rw-r--r--meta-python/recipes-devtools/python/python-pycurl_7.43.0.3.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pycurl_7.43.0.3.bb2
3 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycurl.inc b/meta-python/recipes-devtools/python/python-pycurl.inc
new file mode 100644
index 000000000..ac9a370c4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pycurl.inc
@@ -0,0 +1,26 @@
1SUMMARY = "A Python Interface To The cURL library"
2DESCRIPTION = "\
3PycURL is a Python interface to libcurl, the multiprotocol file \
4transfer library. Similarly to the urllib Python module, PycURL can \
5be used to fetch objects identified by a URL from a Python program \
6"
7SECTION = "devel/python"
8HOMEPAGE = "http://pycurl.io/"
9
10LICENSE = "LGPLv2 | MIT"
11LIC_FILES_CHKSUM = " \
12 file://COPYING-LGPL;md5=4fbd65380cdd255951079008b364516c \
13 file://COPYING-MIT;md5=2df767ed35d8ea83de4a93feb55e7815 \
14"
15
16SRC_URI[md5sum] = "f0ed4c805e8bec734990e2e0ee78568e"
17SRC_URI[sha256sum] = "6f08330c5cf79fa8ef68b9912b9901db7ffd34b63e225dce74db56bb21deda8e"
18
19inherit pypi
20
21PYPI_PACKAGE = "pycurl"
22
23DEPENDS = "\
24 curl \
25 ${PYTHON_PN}\
26"
diff --git a/meta-python/recipes-devtools/python/python-pycurl_7.43.0.3.bb b/meta-python/recipes-devtools/python/python-pycurl_7.43.0.3.bb
new file mode 100644
index 000000000..7ab259265
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pycurl_7.43.0.3.bb
@@ -0,0 +1,2 @@
1inherit setuptools
2require python-pycurl.inc
diff --git a/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.3.bb b/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.3.bb
new file mode 100644
index 000000000..5ad319ae2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.3.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-pycurl.inc