diff options
author | Stefan Agner <stefan.agner@toradex.com> | 2017-04-07 10:32:22 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-18 14:21:39 +0200 |
commit | 104f811a096af0f4a2ddf4359df3fa10d9dd1709 (patch) | |
tree | ef0516bacb5dcde0cb0f6928d217f9631e8081ea /meta-python | |
parent | f66465d4d52a7a0df208a0701e3cb034e9c47bd3 (diff) | |
download | meta-openembedded-104f811a096af0f4a2ddf4359df3fa10d9dd1709.tar.gz |
python-pyalsaaudio: Extend recipe to support Python 3
alsaaudio support Python 3 already, add a Python 3 recipe so we
can build alsaaudio for Python 3.
Signed-off-by: Stefan Agner <stefan.agner@toradex.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
3 files changed, 14 insertions, 12 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyalsaaudio.inc b/meta-python/recipes-devtools/python/python-pyalsaaudio.inc new file mode 100644 index 000000000..d150409a2 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pyalsaaudio.inc | |||
@@ -0,0 +1,11 @@ | |||
1 | SUMMARY = "Support for the Linux 2.6.x ALSA Sound System" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "PSF" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1a3b161aa0fcec32a0c8907a2219ad9d" | ||
5 | |||
6 | SRC_URI[md5sum] = "b46f69561bc85fc52e698b2440ca251e" | ||
7 | SRC_URI[sha256sum] = "84e8f8da544d7f4bd96479ce4a237600077984d9be1d7f16c1d9a492ecf50085" | ||
8 | |||
9 | DEPENDS += "alsa-lib" | ||
10 | |||
11 | RDEPENDS_${PN} += "libasound" | ||
diff --git a/meta-python/recipes-devtools/python/python-pyalsaaudio_0.8.4.bb b/meta-python/recipes-devtools/python/python-pyalsaaudio_0.8.4.bb index b4435702e..e5153421b 100644 --- a/meta-python/recipes-devtools/python/python-pyalsaaudio_0.8.4.bb +++ b/meta-python/recipes-devtools/python/python-pyalsaaudio_0.8.4.bb | |||
@@ -1,13 +1,2 @@ | |||
1 | SUMMARY = "Support for the Linux 2.6.x ALSA Sound System" | 1 | require python-pyalsaaudio.inc |
2 | SECTION = "devel/python" | ||
3 | LICENSE = "PSF" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1a3b161aa0fcec32a0c8907a2219ad9d" | ||
5 | |||
6 | SRC_URI[md5sum] = "b46f69561bc85fc52e698b2440ca251e" | ||
7 | SRC_URI[sha256sum] = "84e8f8da544d7f4bd96479ce4a237600077984d9be1d7f16c1d9a492ecf50085" | ||
8 | |||
9 | DEPENDS += "alsa-lib" | ||
10 | |||
11 | inherit pypi setuptools | 2 | inherit pypi setuptools |
12 | |||
13 | RDEPENDS_${PN} += "libasound" | ||
diff --git a/meta-python/recipes-devtools/python/python3-pyalsaaudio_0.8.4.bb b/meta-python/recipes-devtools/python/python3-pyalsaaudio_0.8.4.bb new file mode 100644 index 000000000..b7da1a43d --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pyalsaaudio_0.8.4.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | require python-pyalsaaudio.inc | ||
2 | inherit pypi setuptools3 | ||