diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-04-13 17:15:51 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-24 11:00:54 +0200 |
commit | 07bbd665e6f22e133964c20326c2ec60a7e2841f (patch) | |
tree | beaa50c524ce223e7522cf4b3f3165f49d2a00e3 /meta-python | |
parent | 7417c35df9d51efed015823a114839b574f67e38 (diff) | |
download | meta-openembedded-07bbd665e6f22e133964c20326c2ec60a7e2841f.tar.gz |
python-lxml,python3-lxml: Fix libxslt format warnings
Found with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
4 files changed, 88 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch b/meta-python/recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch new file mode 100644 index 000000000..efaecd69c --- /dev/null +++ b/meta-python/recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From f8d2c3394767025b3b27b71248b3ecb50480cde7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 13 Apr 2017 17:10:45 -0700 | ||
4 | Subject: [PATCH] lxml.etree: Add empty variadic argument | ||
5 | |||
6 | format checker says that argument 4 is a printf formatted argument | ||
7 | but there is no more arguments to follow | ||
8 | |||
9 | Fixes libxslt format warnings | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | src/lxml/lxml.etree.c | 4 ++-- | ||
14 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/src/lxml/lxml.etree.c b/src/lxml/lxml.etree.c | ||
17 | index d482091..faab06c 100644 | ||
18 | --- a/src/lxml/lxml.etree.c | ||
19 | +++ b/src/lxml/lxml.etree.c | ||
20 | @@ -186086,7 +186086,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p | ||
21 | * except: | ||
22 | */ | ||
23 | __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 228, __pyx_L18_except_error) | ||
24 | - xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26); | ||
25 | + xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, ""); | ||
26 | |||
27 | /* "src/lxml/xsltext.pxi":229 | ||
28 | * c_inst_node.name, _cstr(e)) | ||
29 | @@ -186136,7 +186136,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p | ||
30 | * except: | ||
31 | */ | ||
32 | __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 234, __pyx_L18_except_error) | ||
33 | - xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26); | ||
34 | + xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, ""); | ||
35 | |||
36 | /* "src/lxml/xsltext.pxi":235 | ||
37 | * "Error executing extension element '%s'", c_inst_node.name) | ||
38 | -- | ||
39 | 2.12.2 | ||
40 | |||
diff --git a/meta-python/recipes-devtools/python/python-lxml_3.7.3.bb b/meta-python/recipes-devtools/python/python-lxml_3.7.3.bb index 81ccb12d8..5c93a3f84 100644 --- a/meta-python/recipes-devtools/python/python-lxml_3.7.3.bb +++ b/meta-python/recipes-devtools/python/python-lxml_3.7.3.bb | |||
@@ -1,2 +1,6 @@ | |||
1 | inherit setuptools | 1 | inherit setuptools |
2 | require python-lxml.inc | 2 | require python-lxml.inc |
3 | |||
4 | SRC_URI = "${PYPI_SRC_URI} \ | ||
5 | file://0001-lxml.etree-Add-empty-variadic-argument.patch \ | ||
6 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch b/meta-python/recipes-devtools/python/python3-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch new file mode 100644 index 000000000..bb012dc44 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From 36e64cf2f0676ee422c1fd41456967f3015b2fa3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 13 Apr 2017 17:10:45 -0700 | ||
4 | Subject: [PATCH] lxml.etree: Add empty variadic argument | ||
5 | |||
6 | format checker says that argument 4 is a printf formatted argument | ||
7 | but there is no more arguments to follow | ||
8 | |||
9 | Fixes libxslt format warnings | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | src/lxml/lxml.etree.c | 4 ++-- | ||
14 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/src/lxml/lxml.etree.c b/src/lxml/lxml.etree.c | ||
17 | index d482091..faab06c 100644 | ||
18 | --- a/src/lxml/lxml.etree.c | ||
19 | +++ b/src/lxml/lxml.etree.c | ||
20 | @@ -186086,7 +186086,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p | ||
21 | * except: | ||
22 | */ | ||
23 | __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 228, __pyx_L18_except_error) | ||
24 | - xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26); | ||
25 | + xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, ""); | ||
26 | |||
27 | /* "src/lxml/xsltext.pxi":229 | ||
28 | * c_inst_node.name, _cstr(e)) | ||
29 | @@ -186136,7 +186136,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p | ||
30 | * except: | ||
31 | */ | ||
32 | __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 234, __pyx_L18_except_error) | ||
33 | - xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26); | ||
34 | + xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, ""); | ||
35 | |||
36 | /* "src/lxml/xsltext.pxi":235 | ||
37 | * "Error executing extension element '%s'", c_inst_node.name) | ||
38 | -- | ||
39 | 2.12.2 | ||
40 | |||
diff --git a/meta-python/recipes-devtools/python/python3-lxml_3.7.3.bb b/meta-python/recipes-devtools/python/python3-lxml_3.7.3.bb index ff4bc7faa..8b13d2dd2 100644 --- a/meta-python/recipes-devtools/python/python3-lxml_3.7.3.bb +++ b/meta-python/recipes-devtools/python/python3-lxml_3.7.3.bb | |||
@@ -1,2 +1,6 @@ | |||
1 | inherit setuptools3 | 1 | inherit setuptools3 |
2 | require python-lxml.inc | 2 | require python-lxml.inc |
3 | |||
4 | SRC_URI = "${PYPI_SRC_URI} \ | ||
5 | file://0001-lxml.etree-Add-empty-variadic-argument.patch \ | ||
6 | " | ||