diff options
author | Joris Offouga <offougajoris@gmail.com> | 2018-10-26 10:45:22 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-10-26 21:08:43 -0700 |
commit | 3ad039f79a48926e81522a6f0057885c56d32786 (patch) | |
tree | eca091e0fb88d22eb6d9c2005ba049c2b1685fc0 /meta-python | |
parent | 18efa5fa25bcc6a8d6e28250518593d5ceaac060 (diff) | |
download | meta-openembedded-3ad039f79a48926e81522a6f0057885c56d32786.tar.gz |
] Add recipes for django rest framework
Signed-off-by: Joris Offouga <offougajoris@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
3 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-djangorestframework.inc b/meta-python/recipes-devtools/python/python-djangorestframework.inc new file mode 100644 index 000000000..8551a8341 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-djangorestframework.inc | |||
@@ -0,0 +1,16 @@ | |||
1 | SUMMARY = "djangorestframework" | ||
2 | DESCRIPTION = "pip3 install djangorestframework" | ||
3 | HOMEPAGE = "https://pypi.python.org/pypi/djangorestframework" | ||
4 | |||
5 | LICENSE = "MIT" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=7879a5a716147a784f7e524c9cf103c1" | ||
7 | |||
8 | SRC_URI[md5sum] = "0d481bf8dbb87bb927b46798edc1a9bd" | ||
9 | SRC_URI[sha256sum] = "607865b0bb1598b153793892101d881466bd5a991de12bd6229abb18b1c86136" | ||
10 | PYPI_PACKAGE = "djangorestframework" | ||
11 | |||
12 | inherit pypi | ||
13 | |||
14 | RDEPENDS_${PN} += "\ | ||
15 | ${PYTHON_PN}-django \ | ||
16 | " \ No newline at end of file | ||
diff --git a/meta-python/recipes-devtools/python/python-djangorestframework_3.9.0.bb b/meta-python/recipes-devtools/python/python-djangorestframework_3.9.0.bb new file mode 100644 index 000000000..540d12dc2 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-djangorestframework_3.9.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | require python-djangorestframework.inc | ||
2 | inherit setuptools \ No newline at end of file | ||
diff --git a/meta-python/recipes-devtools/python/python3-djangorestframework_3.9.0.bb b/meta-python/recipes-devtools/python/python3-djangorestframework_3.9.0.bb new file mode 100644 index 000000000..9ed6d1726 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-djangorestframework_3.9.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | require python-djangorestframework.inc | ||
2 | inherit setuptools3 \ No newline at end of file | ||