summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2019-02-05 11:57:35 -0800
committerKhem Raj <raj.khem@gmail.com>2019-02-06 08:19:13 -0800
commitf6e0ee746b633a2632980221d02ff704c524e7b4 (patch)
tree0cb54fd267f644bb287bb067edec7d770adef5c2 /meta-python
parentc19f3a7716abd9802fd007200519de6c5904e7f8 (diff)
downloadmeta-openembedded-f6e0ee746b633a2632980221d02ff704c524e7b4.tar.gz
python3-twitter_3.7.0.bb: Yocto recipes for tweepy packages
Yocto recipes for easy to use python2 and python3 libraries for accessing twitter APIs Signed-off-by: Sai Hari Chandana Kalluri <chandana.kalluri@xilinx.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-twitter.inc17
-rw-r--r--meta-python/recipes-devtools/python/python-twitter_3.7.0.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-twitter_3.7.0.bb3
3 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-twitter.inc b/meta-python/recipes-devtools/python/python-twitter.inc
new file mode 100644
index 000000000..f5657eeb2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-twitter.inc
@@ -0,0 +1,17 @@
1SUMMARY = "Twitter for Python"
2DESCRIPTION = "Python module to support twitter API"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=0307fffd8c4d9946c029daa1426d26e7"
6
7SRC_URI[md5sum] = "c6dc2f315ded761aafc96bea3351c7f6"
8SRC_URI[sha256sum] = "fe85a79f58a01dd335968523b91c5fce760e7fe78bf25a6e71c72204fe499d0b"
9
10PYPI_PACKAGE = "tweepy"
11
12RDEPENDS_${PN} += "\
13 ${PYTHON_PN}-pip \
14 ${PYTHON_PN}-pysocks \
15 ${PYTHON_PN}-requests \
16 ${PYTHON_PN}-six \
17 "
diff --git a/meta-python/recipes-devtools/python/python-twitter_3.7.0.bb b/meta-python/recipes-devtools/python/python-twitter_3.7.0.bb
new file mode 100644
index 000000000..6a28b08ae
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-twitter_3.7.0.bb
@@ -0,0 +1,3 @@
1require python-twitter.inc
2inherit pypi setuptools
3
diff --git a/meta-python/recipes-devtools/python/python3-twitter_3.7.0.bb b/meta-python/recipes-devtools/python/python3-twitter_3.7.0.bb
new file mode 100644
index 000000000..c2e4d2ebd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-twitter_3.7.0.bb
@@ -0,0 +1,3 @@
1require python-twitter.inc
2inherit pypi setuptools3
3