summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-07-17 07:52:00 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-22 21:45:41 +0200
commitd070f5afe9a904ee33d2f87f0e23115ba00bcd5a (patch)
treedd7cae304c8bdb592eb5c7a11fb6707c0708c7a4 /meta-python
parenta7195fc96919e7ee45aa6c2f08b44995c3d8b7a7 (diff)
downloadmeta-openembedded-d070f5afe9a904ee33d2f87f0e23115ba00bcd5a.tar.gz
python-click: add recipe for the python click package required by the new version of flask
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-click.inc17
-rw-r--r--meta-python/recipes-devtools/python/python-click_6.6.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-click_6.6.bb2
3 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-click.inc b/meta-python/recipes-devtools/python/python-click.inc
new file mode 100644
index 000000000..f3d5b3604
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-click.inc
@@ -0,0 +1,17 @@
1SUMMARY = "A simple wrapper around optparse for powerful command line utilities."
2DESCRIPTION = "\
3Click is a Python package for creating beautiful command line interfaces \
4in a composable way with as little code as necessary. It's the "Command \
5Line Interface Creation Kit". It's highly configurable but comes with \
6sensible defaults out of the box."
7HOMEPAGE = "http://click.pocoo.org/"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=09e8b7869f94ba9e9a7b260d53c65dab"
10
11SRC_URI[md5sum] = "d0b09582123605220ad6977175f3e51d"
12SRC_URI[sha256sum] = "cc6a19da8ebff6e7074f731447ef7e112bd23adf3de5c597cf9989f2fd8defe9"
13
14RDEPENDS_${PN} += "\
15 ${PYTHON_PN}-io \
16 ${PYTHON_PN}-threading \
17 "
diff --git a/meta-python/recipes-devtools/python/python-click_6.6.bb b/meta-python/recipes-devtools/python/python-click_6.6.bb
new file mode 100644
index 000000000..f63e27c84
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-click_6.6.bb
@@ -0,0 +1,4 @@
1inherit pypi setuptools
2require python-click.inc
3
4RDEPENDS_${PN} += "${PYTHON_PN}-contextlib"
diff --git a/meta-python/recipes-devtools/python/python3-click_6.6.bb b/meta-python/recipes-devtools/python/python3-click_6.6.bb
new file mode 100644
index 000000000..192064404
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-click_6.6.bb
@@ -0,0 +1,2 @@
1inherit pypi setuptools3
2require python-click.inc