summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorCallaghan, Dan <dan.callaghan@opengear.com>2019-01-30 07:22:08 +0000
committerKhem Raj <raj.khem@gmail.com>2019-02-01 06:57:14 -0800
commit53cb161e6c475708b9ca3a1ec570592c868ca392 (patch)
tree13d907eafcc99af05f7b0e29bca3e94f9796ac2a /meta-python
parentc3a5c5c3ebe69543ee653e11041aa78fb245bd2f (diff)
downloadmeta-openembedded-53cb161e6c475708b9ca3a1ec570592c868ca392.tar.gz
python-slip-dbus: add a python3 version of the recipe
Signed-off-by: Dan Callaghan <dan.callaghan@opengear.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-slip-dbus.inc29
-rw-r--r--meta-python/recipes-devtools/python/python-slip-dbus_0.6.5.bb31
-rw-r--r--meta-python/recipes-devtools/python/python3-slip-dbus_0.6.5.bb2
3 files changed, 32 insertions, 30 deletions
diff --git a/meta-python/recipes-devtools/python/python-slip-dbus.inc b/meta-python/recipes-devtools/python/python-slip-dbus.inc
new file mode 100644
index 000000000..0933b4559
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-slip-dbus.inc
@@ -0,0 +1,29 @@
1SUMMARY = "Convenience functions for dbus services in Python 2.x"
2HOMEPAGE = "https://github.com/nphilipp/python-slip"
3DESCRIPTION = "\
4The Simple Library for Python 2.x packages contain miscellaneous code for \
5convenience, extension and workaround purposes. \
6\
7This package provides slip.dbus.service.Object, which is a dbus.service.Object \
8derivative that ends itself after a certain time without being used and/or if \
9there are no clients anymore on the message bus, as well as convenience \
10functions and decorators for integrating a dbus service with PolicyKit."
11
12SECTION = "devel/python"
13LICENSE = "GPLv2+"
14LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
15SRCNAME = "python-slip"
16
17SRC_URI = "https://github.com/nphilipp/${SRCNAME}/releases/download/${SRCNAME}-${PV}/${SRCNAME}-${PV}.tar.bz2"
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20SRC_URI[md5sum] = "28ae5f93853466c44ec96706ba2a1eb4"
21SRC_URI[sha256sum] = "c726c086f0dd93a0ac7a0176f383a12af91b6657b78a301e3f5b25d9f8d4d10b"
22
23do_compile_prepend() {
24 sed -e 's/@VERSION@/${PV}/g' setup.py.in > setup.py
25}
26
27# http://errors.yoctoproject.org/Errors/Details/184713/
28# python-native/python: can't open file 'setup.py': [Errno 2] No such file or directory
29CLEANBROKEN = "1"
diff --git a/meta-python/recipes-devtools/python/python-slip-dbus_0.6.5.bb b/meta-python/recipes-devtools/python/python-slip-dbus_0.6.5.bb
index c2675cbdd..330fa1ba4 100644
--- a/meta-python/recipes-devtools/python/python-slip-dbus_0.6.5.bb
+++ b/meta-python/recipes-devtools/python/python-slip-dbus_0.6.5.bb
@@ -1,31 +1,2 @@
1SUMMARY = "Convenience functions for dbus services in Python 2.x"
2HOMEPAGE = "https://github.com/nphilipp/python-slip"
3DESCRIPTION = "\
4The Simple Library for Python 2.x packages contain miscellaneous code for \
5convenience, extension and workaround purposes. \
6\
7This package provides slip.dbus.service.Object, which is a dbus.service.Object \
8derivative that ends itself after a certain time without being used and/or if \
9there are no clients anymore on the message bus, as well as convenience \
10functions and decorators for integrating a dbus service with PolicyKit."
11
12SECTION = "devel/python"
13LICENSE = "GPLv2+"
14LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
15SRCNAME = "python-slip"
16
17SRC_URI = "https://github.com/nphilipp/${SRCNAME}/releases/download/${SRCNAME}-${PV}/${SRCNAME}-${PV}.tar.bz2"
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20inherit setuptools 1inherit setuptools
21 2require python-slip-dbus.inc
22SRC_URI[md5sum] = "28ae5f93853466c44ec96706ba2a1eb4"
23SRC_URI[sha256sum] = "c726c086f0dd93a0ac7a0176f383a12af91b6657b78a301e3f5b25d9f8d4d10b"
24
25do_compile_prepend() {
26 sed -e 's/@VERSION@/${PV}/g' setup.py.in > setup.py
27}
28
29# http://errors.yoctoproject.org/Errors/Details/184713/
30# python-native/python: can't open file 'setup.py': [Errno 2] No such file or directory
31CLEANBROKEN = "1"
diff --git a/meta-python/recipes-devtools/python/python3-slip-dbus_0.6.5.bb b/meta-python/recipes-devtools/python/python3-slip-dbus_0.6.5.bb
new file mode 100644
index 000000000..2402a7a74
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-slip-dbus_0.6.5.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-slip-dbus.inc