diff options
author | Andreas Oberritter <obi@opendreambox.org> | 2015-03-27 23:21:02 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-04-13 12:55:49 +0200 |
commit | 6a0641398d4b161253afe9bfd744ce0fd5950bc6 (patch) | |
tree | b36c91ded76115dc35a96922f95e016d37e6b5a5 /meta-python | |
parent | c9e06339057d8999bd0e056e679368c1a2fab013 (diff) | |
download | meta-openembedded-6a0641398d4b161253afe9bfd744ce0fd5950bc6.tar.gz |
python-pyopenssl: Downgrade to 0.13
Version 0.14 depends python-cryptography, which is
currently unavailable in meta-openembedded.
Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pyopenssl-0.13/x509_revoked_dup.patch | 19 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-pyopenssl_0.13.bb (renamed from meta-python/recipes-devtools/python/python-pyopenssl_0.14.bb) | 11 |
2 files changed, 25 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyopenssl-0.13/x509_revoked_dup.patch b/meta-python/recipes-devtools/python/python-pyopenssl-0.13/x509_revoked_dup.patch new file mode 100644 index 000000000..c386e9ccd --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pyopenssl-0.13/x509_revoked_dup.patch | |||
@@ -0,0 +1,19 @@ | |||
1 | diff -Naur pyOpenSSL-0.13.orig/OpenSSL/crypto/crl.c pyOpenSSL-0.13/OpenSSL/crypto/crl.c | ||
2 | --- pyOpenSSL-0.13.orig/OpenSSL/crypto/crl.c 2011-09-02 17:46:13.000000000 +0200 | ||
3 | +++ pyOpenSSL-0.13/OpenSSL/crypto/crl.c 2015-03-26 20:53:08.984999223 +0100 | ||
4 | @@ -3,6 +3,7 @@ | ||
5 | #include "crypto.h" | ||
6 | |||
7 | |||
8 | +#if 0 | ||
9 | static X509_REVOKED * X509_REVOKED_dup(X509_REVOKED *orig) { | ||
10 | X509_REVOKED *dupe = NULL; | ||
11 | |||
12 | @@ -32,6 +33,7 @@ | ||
13 | dupe->sequence = orig->sequence; | ||
14 | return dupe; | ||
15 | } | ||
16 | +#endif | ||
17 | |||
18 | static char crypto_CRL_get_revoked_doc[] = "\n\ | ||
19 | Return revoked portion of the CRL structure (by value\n\ | ||
diff --git a/meta-python/recipes-devtools/python/python-pyopenssl_0.14.bb b/meta-python/recipes-devtools/python/python-pyopenssl_0.13.bb index 1f609e36f..cf9d73e63 100644 --- a/meta-python/recipes-devtools/python/python-pyopenssl_0.14.bb +++ b/meta-python/recipes-devtools/python/python-pyopenssl_0.13.bb | |||
@@ -7,15 +7,16 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | |||
7 | SRCNAME = "pyOpenSSL" | 7 | SRCNAME = "pyOpenSSL" |
8 | 8 | ||
9 | DEPENDS = "openssl" | 9 | DEPENDS = "openssl" |
10 | PE = "1" | ||
10 | 11 | ||
11 | SRC_URI = "http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-${PV}.tar.gz" | 12 | SRC_URI = "http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-${PV}.tar.gz \ |
12 | 13 | file://x509_revoked_dup.patch" | |
13 | SRC_URI[md5sum] = "8579ff3a1d858858acfba5f046a4ddf7" | 14 | SRC_URI[md5sum] = "767bca18a71178ca353dff9e10941929" |
14 | SRC_URI[sha256sum] = "a99db8e59c120138ad8a72eecedcc24b4510d2eed3ce48213b7e32f22cc4ee6e" | 15 | SRC_URI[sha256sum] = "21e12b03abaa0e04ecc8cd9c251598f71bae11c9f385304234e4ea5618c6163b" |
15 | 16 | ||
16 | S = "${WORKDIR}/${SRCNAME}-${PV}" | 17 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
17 | 18 | ||
18 | inherit setuptools | 19 | inherit distutils |
19 | 20 | ||
20 | PACKAGES =+ "${PN}-tests" | 21 | PACKAGES =+ "${PN}-tests" |
21 | FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test" | 22 | FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test" |