diff options
author | Armin Kuster <akuster@mvista.com> | 2016-03-23 14:53:03 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-03-25 11:27:33 +0100 |
commit | 44f0e74954628d6a3d04fa5249dbe0c94f6dff59 (patch) | |
tree | 2581a1289077aa804c5b093de1054a41427ca3e0 /meta-python | |
parent | 0e6e40696de199ddddaaae801ced016aea9dd722 (diff) | |
download | meta-openembedded-44f0e74954628d6a3d04fa5249dbe0c94f6dff59.tar.gz |
python-crytograph: fix build issue do to openssl 1.0.1g upgrade
this fixes
build/temp.linux-x86_64-2.7/_openssl.c:697:6: error: conflicting types for 'BIO_new_mem_buf'
BIO *BIO_new_mem_buf(void *, int);
^
In file included from /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm/usr/include/openssl/asn1.h:65:0,
from build/temp.linux-x86_64-2.7/_openssl.c:413:
Signed-off-by: Armin Kuster <akuster@mvista.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-cryptography/build_fix_openssl_1.0.1g.patch | 28 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-cryptography_1.1.bb | 3 |
2 files changed, 30 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography/build_fix_openssl_1.0.1g.patch b/meta-python/recipes-devtools/python/python-cryptography/build_fix_openssl_1.0.1g.patch new file mode 100644 index 000000000..d08994fe8 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-cryptography/build_fix_openssl_1.0.1g.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | build issue do to openssl 1.0.1g upgrade | ||
2 | |||
3 | BIO *BIO_new_mem_buf(void *, int); | ||
4 | ^ | ||
5 | In file included from /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm/usr/include/openssl/asn1.h:65:0, | ||
6 | from build/temp.linux-x86_64-2.7/_openssl.c:413: | ||
7 | |||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | seems to be a known issue | ||
12 | https://github.com/pyca/cryptography/issues/2750 | ||
13 | |||
14 | Signed-off-by: Armin Kuster <akuster@mvista.com> | ||
15 | |||
16 | Index: src/_cffi_src/openssl/bio.py | ||
17 | =================================================================== | ||
18 | --- a/src/_cffi_src/openssl/bio.py | ||
19 | +++ b/src/_cffi_src/openssl/bio.py | ||
20 | @@ -99,7 +99,7 @@ BIO *BIO_pop(BIO *); | ||
21 | BIO *BIO_next(BIO *); | ||
22 | BIO *BIO_find_type(BIO *, int); | ||
23 | BIO_METHOD *BIO_s_mem(void); | ||
24 | -BIO *BIO_new_mem_buf(void *, int); | ||
25 | +BIO *BIO_new_mem_buf(const void *, int); | ||
26 | BIO_METHOD *BIO_s_file(void); | ||
27 | BIO *BIO_new_file(const char *, const char *); | ||
28 | BIO *BIO_new_fp(FILE *, int); | ||
diff --git a/meta-python/recipes-devtools/python/python-cryptography_1.1.bb b/meta-python/recipes-devtools/python/python-cryptography_1.1.bb index ffc8fd9dc..c501787af 100644 --- a/meta-python/recipes-devtools/python/python-cryptography_1.1.bb +++ b/meta-python/recipes-devtools/python/python-cryptography_1.1.bb | |||
@@ -4,7 +4,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4" | |||
4 | DEPENDS += " python-cffi-native python-cffi python-enum34 python-six python-pyasn1" | 4 | DEPENDS += " python-cffi-native python-cffi python-enum34 python-six python-pyasn1" |
5 | SRCNAME = "cryptography" | 5 | SRCNAME = "cryptography" |
6 | 6 | ||
7 | SRC_URI = "file://run-ptest" | 7 | SRC_URI = "file://run-ptest \ |
8 | file://build_fix_openssl_1.0.1g.patch" | ||
8 | 9 | ||
9 | SRC_URI[md5sum] = "dd06da41535184f48f2c8e8b74dd570f" | 10 | SRC_URI[md5sum] = "dd06da41535184f48f2c8e8b74dd570f" |
10 | SRC_URI[sha256sum] = "059bc6428b1d0e2317f505698602642f1d8dda5b120ec573a59a430d8cb7a32d" | 11 | SRC_URI[sha256sum] = "059bc6428b1d0e2317f505698602642f1d8dda5b120ec573a59a430d8cb7a32d" |