diff options
author | Fabio Berton <fabio.berton@ossystems.com.br> | 2016-08-17 10:17:48 -0300 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-08-22 15:49:28 +0200 |
commit | b7ab1526c2ec3b09795389050035aab7f961bf68 (patch) | |
tree | 576c31386739e1753336183941257317009b3677 /meta-python | |
parent | 25b5e35df5c4d61ac9ba44cf443ef2d68a16fc2c (diff) | |
download | meta-openembedded-b7ab1526c2ec3b09795389050035aab7f961bf68.tar.gz |
python-jsonschema, python3-jsonschema: Add recipe for version 2.5.1
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
3 files changed, 40 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-jsonschema.inc b/meta-python/recipes-devtools/python/python-jsonschema.inc new file mode 100644 index 000000000..3466457e0 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-jsonschema.inc | |||
@@ -0,0 +1,26 @@ | |||
1 | SUMMARY = "An implementation of JSON Schema validation for Python" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8" | ||
4 | |||
5 | SRC_URI[md5sum] = "374e848fdb69a3ce8b7e778b47c30640" | ||
6 | SRC_URI[sha256sum] = "36673ac378feed3daa5956276a829699056523d7961027911f064b52255ead41" | ||
7 | |||
8 | RDEPENDS_${PN} += " \ | ||
9 | ${PYTHON_PN}-core \ | ||
10 | ${PYTHON_PN}-io \ | ||
11 | ${PYTHON_PN}-json \ | ||
12 | ${PYTHON_PN}-lang \ | ||
13 | ${PYTHON_PN}-netclient \ | ||
14 | ${PYTHON_PN}-numbers \ | ||
15 | ${PYTHON_PN}-pkgutil \ | ||
16 | ${PYTHON_PN}-pprint \ | ||
17 | ${PYTHON_PN}-re \ | ||
18 | ${PYTHON_PN}-rfc3987 \ | ||
19 | ${PYTHON_PN}-shell \ | ||
20 | ${PYTHON_PN}-strict-rfc3339 \ | ||
21 | ${PYTHON_PN}-subprocess \ | ||
22 | ${PYTHON_PN}-textutils \ | ||
23 | ${PYTHON_PN}-unittest \ | ||
24 | " | ||
25 | |||
26 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python-jsonschema_2.5.1.bb b/meta-python/recipes-devtools/python/python-jsonschema_2.5.1.bb new file mode 100644 index 000000000..3bb522018 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-jsonschema_2.5.1.bb | |||
@@ -0,0 +1,8 @@ | |||
1 | inherit pypi setuptools | ||
2 | require python-jsonschema.inc | ||
3 | |||
4 | RDEPENDS_${PN} += " \ | ||
5 | ${PYTHON_PN}-argparse \ | ||
6 | ${PYTHON_PN}-contextlib \ | ||
7 | ${PYTHON_PN}-functools32 \ | ||
8 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-jsonschema_2.5.1.bb b/meta-python/recipes-devtools/python/python3-jsonschema_2.5.1.bb new file mode 100644 index 000000000..5aaee682b --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-jsonschema_2.5.1.bb | |||
@@ -0,0 +1,6 @@ | |||
1 | inherit pypi setuptools3 | ||
2 | require python-jsonschema.inc | ||
3 | |||
4 | RDEPENDS_${PN} += " \ | ||
5 | ${PYTHON_PN}-misc \ | ||
6 | " | ||