diff options
author | Andrej Rode <andrej.rode@ettus.com> | 2017-04-13 13:47:14 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-24 10:59:26 +0200 |
commit | b2217b9cd80297682297ad055136da6345d69b76 (patch) | |
tree | 14bee7da3fbae2ca6a21b42e53d57de46c27df5a /meta-python | |
parent | 74f9dcd4b8c072dc097ef591fa50eaf7493c68f5 (diff) | |
download | meta-openembedded-b2217b9cd80297682297ad055136da6345d69b76.tar.gz |
python-systemd, python3-systemd: add a new recipes
Adds new recipe for python-systemd and python3-systemd
which provide python bindings for libsystemd
Signed-off-by: Andrej Rode <andrej.rode@ettus.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-systemd_234.bb | 13 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-systemd_234.bb | 13 |
2 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-systemd_234.bb b/meta-python/recipes-devtools/python/python-systemd_234.bb new file mode 100644 index 000000000..ef1183171 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-systemd_234.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | SUMMARY = "Python interface for libsystemd" | ||
2 | HOMEPAGE = "https://github.com/systemd/python-systemd" | ||
3 | LICENSE = "LGPLv2.1+" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4fbd65380cdd255951079008b364516c" | ||
5 | |||
6 | PYPI_PACKAGE = "systemd-python" | ||
7 | DEPENDS += "systemd (<=234)" | ||
8 | RDEPENDS_${PN} += "systemd" | ||
9 | REQUIRED_DISTRO_FEATURES = "systemd" | ||
10 | inherit pypi setuptools distro_features_check | ||
11 | |||
12 | SRC_URI[md5sum] = "5071ea5bcb976186e92a3f5e75df221d" | ||
13 | SRC_URI[sha256sum] = "fd0e44bf70eadae45aadc292cb0a7eb5b0b6372cd1b391228047d33895db83e7" | ||
diff --git a/meta-python/recipes-devtools/python/python3-systemd_234.bb b/meta-python/recipes-devtools/python/python3-systemd_234.bb new file mode 100644 index 000000000..845b7d9e1 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-systemd_234.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | SUMMARY = "Python interface for libsystemd" | ||
2 | HOMEPAGE = "https://github.com/systemd/python-systemd" | ||
3 | LICENSE = "LGPLv2.1+" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4fbd65380cdd255951079008b364516c" | ||
5 | |||
6 | PYPI_PACKAGE = "systemd-python" | ||
7 | DEPENDS += "systemd (<=234)" | ||
8 | RDEPENDS_${PN} += "systemd" | ||
9 | REQUIRED_DISTRO_FEATURES = "systemd" | ||
10 | inherit pypi setuptools3 distro_features_check | ||
11 | |||
12 | SRC_URI[md5sum] = "5071ea5bcb976186e92a3f5e75df221d" | ||
13 | SRC_URI[sha256sum] = "fd0e44bf70eadae45aadc292cb0a7eb5b0b6372cd1b391228047d33895db83e7" | ||