summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@cold-front.org>2022-03-14 18:01:39 -0400
committertgamblin <trevor.gamblin@windriver.com>2022-03-15 15:34:22 -0400
commitf5a978bb7ed047537eb98306cf87704983907693 (patch)
treec252a14b899dd67e82ae061971a5e08bf2115708 /meta-python
parentf792874431dd4961364a4e75df3d5a3b850116d6 (diff)
downloadmeta-openembedded-f5a978bb7ed047537eb98306cf87704983907693.tar.gz
python3-pymodbus: add asyncio to package config
When using asyncio as the backend for asynchronous communication, pymodbus depends on python3-pyserial-asyncio. Signed-off-by: Justin Bronder <jsbronder@cold-front.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: tgamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pymodbus_2.5.3.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymodbus_2.5.3.bb b/meta-python/recipes-devtools/python/python3-pymodbus_2.5.3.bb
index b628cadaf..46565876f 100644
--- a/meta-python/recipes-devtools/python/python3-pymodbus_2.5.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pymodbus_2.5.3.bb
@@ -11,6 +11,7 @@ inherit pypi setuptools3
11 11
12PACKAGECONFIG ??= "" 12PACKAGECONFIG ??= ""
13PACKAGECONFIG[repl] = ",,,python3-aiohttp python3-click python3-prompt-toolkit python3-pygments python3-pyserial-asyncio" 13PACKAGECONFIG[repl] = ",,,python3-aiohttp python3-click python3-prompt-toolkit python3-pygments python3-pyserial-asyncio"
14PACKAGECONFIG[asyncio] = ",,,python3-pyserial-asyncio"
14PACKAGECONFIG[tornado] = ",,,python3-tornado" 15PACKAGECONFIG[tornado] = ",,,python3-tornado"
15PACKAGECONFIG[twisted] = ",,,python3-twisted-conch" 16PACKAGECONFIG[twisted] = ",,,python3-twisted-conch"
16PACKAGECONFIG[redis] = ",,,python3-redis" 17PACKAGECONFIG[redis] = ",,,python3-redis"