diff options
author | Zang Ruochen <zangrc.fnst@cn.fujitsu.com> | 2020-01-02 16:34:21 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-01-02 09:48:20 -0800 |
commit | f4aa4b6dd9ebf6a0d78f85d81ad34672b2d68633 (patch) | |
tree | 1a70d49ab04d879c9195043af7af1457a9f9510e /meta-python | |
parent | b0457789777ae8b1c1d24a09381a184ff94d60b7 (diff) | |
download | meta-openembedded-f4aa4b6dd9ebf6a0d78f85d81ad34672b2d68633.tar.gz |
python-backports-functools-lru-cache: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
3 files changed, 23 insertions, 19 deletions
diff --git a/meta-python/recipes-devtools/python/python-backports-functools-lru-cache.inc b/meta-python/recipes-devtools/python/python-backports-functools-lru-cache.inc new file mode 100644 index 000000000..bce44a28b --- /dev/null +++ b/meta-python/recipes-devtools/python/python-backports-functools-lru-cache.inc | |||
@@ -0,0 +1,19 @@ | |||
1 | SUMMARY = "Backport of functools.lru_cache from Python 3.3" | ||
2 | HOMEPAGE = "https://github.com/jaraco/backports.functools_lru_cache" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://setup.py;beginline=57;endline=57;md5=98fc3658e5970d26f6b2109808c766be" | ||
6 | |||
7 | PYPI_PACKAGE = "backports.functools_lru_cache" | ||
8 | |||
9 | SRC_URI[md5sum] = "20f53f54cd3f04b3346ce75a54959754" | ||
10 | SRC_URI[sha256sum] = "9d98697f088eb1b0fa451391f91afb5e3ebde16bbdb272819fd091151fda4f1a" | ||
11 | |||
12 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" | ||
13 | |||
14 | inherit pypi | ||
15 | |||
16 | RDEPENDS_${PN} += "\ | ||
17 | ${PYTHON_PN}-pickle \ | ||
18 | ${PYTHON_PN}-threading \ | ||
19 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-backports-functools-lru-cache_1.5.bb b/meta-python/recipes-devtools/python/python-backports-functools-lru-cache_1.5.bb index 825444ff3..5e0f2f1e8 100644 --- a/meta-python/recipes-devtools/python/python-backports-functools-lru-cache_1.5.bb +++ b/meta-python/recipes-devtools/python/python-backports-functools-lru-cache_1.5.bb | |||
@@ -1,19 +1,2 @@ | |||
1 | SUMMARY = "Backport of functools.lru_cache from Python 3.3" | 1 | require python-backports-functools-lru-cache.inc |
2 | HOMEPAGE = "https://github.com/jaraco/backports.functools_lru_cache" | 2 | inherit setuptools |
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://setup.py;beginline=57;endline=57;md5=98fc3658e5970d26f6b2109808c766be" | ||
6 | |||
7 | PYPI_PACKAGE = "backports.functools_lru_cache" | ||
8 | |||
9 | SRC_URI[md5sum] = "20f53f54cd3f04b3346ce75a54959754" | ||
10 | SRC_URI[sha256sum] = "9d98697f088eb1b0fa451391f91afb5e3ebde16bbdb272819fd091151fda4f1a" | ||
11 | |||
12 | DEPENDS += "python-setuptools-scm-native" | ||
13 | |||
14 | inherit setuptools pypi | ||
15 | |||
16 | RDEPENDS_${PN} += "\ | ||
17 | ${PYTHON_PN}-pickle \ | ||
18 | ${PYTHON_PN}-threading \ | ||
19 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.5.bb b/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.5.bb new file mode 100644 index 000000000..91fcc41fc --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-backports-functools-lru-cache_1.5.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | require python-backports-functools-lru-cache.inc | ||
2 | inherit setuptools3 | ||