summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-02-25 09:31:51 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-28 08:32:19 -0800
commitefcbd827a43d7ae8962ed620b0eac9f5273b3060 (patch)
tree2f4e6fc7cb1e629cb6994029578c4275ded253ea /meta-python
parent4d3063b1f8ef4229834399257f09a5f50a023c37 (diff)
downloadmeta-openembedded-efcbd827a43d7ae8962ed620b0eac9f5273b3060.tar.gz
python3-setuptools-rust-native: fix wheel build
Add comment that setuptools_build_meta is currently broken and stick with setuptools3 for now. For some reason, the wheel is built in ${S}/dist and not ${B}/dist. Set PIP_INSTALL_DIST_PATH accordingly as a workaround. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb b/meta-python/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb
index 34ff91241..1afb3f0e0 100644
--- a/meta-python/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb
+++ b/meta-python/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb
@@ -12,8 +12,15 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=011cd92e702dd9e6b1a26157b6fd53f5"
12SRC_URI = "https://files.pythonhosted.org/packages/67/08/e1aa2c582c62ac76e4d60f8e454bd3bba933781a06a88b4e38797445822a/setuptools-rust-${PV}.tar.gz" 12SRC_URI = "https://files.pythonhosted.org/packages/67/08/e1aa2c582c62ac76e4d60f8e454bd3bba933781a06a88b4e38797445822a/setuptools-rust-${PV}.tar.gz"
13SRC_URI[sha256sum] = "a0adb9b503c0ffc4e8fe80b7c617898cefa78049983aaaea7f747e153a3e65d1" 13SRC_URI[sha256sum] = "a0adb9b503c0ffc4e8fe80b7c617898cefa78049983aaaea7f747e153a3e65d1"
14 14
15# While this has a pyproject.toml and declares that setuptools_build_meta should work
16# it results in a wheel named UNKNOWN-0.0.0-py3-none-any.whl so stay with setuptools3
17# until that can be resolved
15inherit cargo pypi setuptools3 native 18inherit cargo pypi setuptools3 native
16 19
20# For some reason the wheel is built in ${S} not ${B}
21PIP_INSTALL_DIST_PATH = "${S}/dist"
22
23
17DEPENDS += "python3-setuptools-scm-native python3-wheel-native" 24DEPENDS += "python3-setuptools-scm-native python3-wheel-native"
18 25
19RDEPENDS:${PN}:class-native += " \ 26RDEPENDS:${PN}:class-native += " \