diff options
author | Wang Mingyu <wangmy@cn.fujitsu.com> | 2020-01-13 09:09:41 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-01-13 18:34:32 -0800 |
commit | dcb8c50af47a14dfd0c03097df92b2b8c4782b45 (patch) | |
tree | 277f6b7cc37772035df32a11118e26d6aa7cea60 /meta-python | |
parent | d612ea4094945bde499c46df09ff33e38950a2dc (diff) | |
download | meta-openembedded-dcb8c50af47a14dfd0c03097df92b2b8c4782b45.tar.gz |
python-pyconnman: 0.1.0 -> 0.2.0
0001-Import-local-modules-by-relative-path-for-python3-su.patch
Removed since it is included in 0.2.0.
Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-connectivity/python-pyconnman/python-pyconnman.inc | 4 | ||||
-rw-r--r-- | meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.2.0.bb (renamed from meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.1.0.bb) | 0 | ||||
-rw-r--r-- | meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman/0001-Import-local-modules-by-relative-path-for-python3-su.patch | 74 | ||||
-rw-r--r-- | meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.1.0.bb | 9 | ||||
-rw-r--r-- | meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.2.0.bb | 5 |
5 files changed, 7 insertions, 85 deletions
diff --git a/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman.inc b/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman.inc index beb2baf83..8517079bf 100644 --- a/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman.inc +++ b/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman.inc | |||
@@ -4,8 +4,8 @@ LICENSE = "Apache-2.0" | |||
4 | 4 | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
6 | 6 | ||
7 | SRC_URI[md5sum] = "b7fa82034b1c0e1fb1b518ffe3bb4fc0" | 7 | SRC_URI[md5sum] = "d60bdffbd9c920f005fdc5e05a8b94cd" |
8 | SRC_URI[sha256sum] = "46c64c0692063fd0c9fb0216d49f7884bec9fa9760d8473db4b1e2f8162fab4a" | 8 | SRC_URI[sha256sum] = "d3a63a039c82b08a1171b003eafa62c6f128aa4eaa1ce7a55a9401b48f9ad926" |
9 | 9 | ||
10 | inherit pypi | 10 | inherit pypi |
11 | 11 | ||
diff --git a/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.1.0.bb b/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.2.0.bb index 3c12db944..3c12db944 100644 --- a/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.1.0.bb +++ b/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.2.0.bb | |||
diff --git a/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman/0001-Import-local-modules-by-relative-path-for-python3-su.patch b/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman/0001-Import-local-modules-by-relative-path-for-python3-su.patch deleted file mode 100644 index 977b4aacd..000000000 --- a/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman/0001-Import-local-modules-by-relative-path-for-python3-su.patch +++ /dev/null | |||
@@ -1,74 +0,0 @@ | |||
1 | From 2e84adb042bfb742eb328220b97f79ddb28db44b Mon Sep 17 00:00:00 2001 | ||
2 | From: Haris Okanovic <haris.okanovic@ni.com> | ||
3 | Date: Tue, 23 Oct 2018 21:39:56 +0000 | ||
4 | Subject: [PATCH] Import local modules by relative path for python3 support | ||
5 | |||
6 | Upstream-Status: Submitted | ||
7 | --- | ||
8 | pyconnman/agent.py | 2 +- | ||
9 | pyconnman/interface.py | 2 +- | ||
10 | pyconnman/manager.py | 2 +- | ||
11 | pyconnman/service.py | 2 +- | ||
12 | pyconnman/technology.py | 2 +- | ||
13 | 5 files changed, 5 insertions(+), 5 deletions(-) | ||
14 | |||
15 | diff --git a/pyconnman/agent.py b/pyconnman/agent.py | ||
16 | index f72de8d..453d783 100644 | ||
17 | --- a/pyconnman/agent.py | ||
18 | +++ b/pyconnman/agent.py | ||
19 | @@ -1,5 +1,5 @@ | ||
20 | from __future__ import unicode_literals | ||
21 | -from exceptions import ConnCanceledException | ||
22 | +from .exceptions import ConnCanceledException | ||
23 | |||
24 | import dbus.service | ||
25 | |||
26 | diff --git a/pyconnman/interface.py b/pyconnman/interface.py | ||
27 | index 7d82e04..d540c81 100644 | ||
28 | --- a/pyconnman/interface.py | ||
29 | +++ b/pyconnman/interface.py | ||
30 | @@ -4,7 +4,7 @@ import dbus | ||
31 | import types | ||
32 | import pprint | ||
33 | |||
34 | -from exceptions import ConnSignalNameNotRecognisedException | ||
35 | +from .exceptions import ConnSignalNameNotRecognisedException | ||
36 | |||
37 | |||
38 | def translate_to_dbus_type(typeof, value): | ||
39 | diff --git a/pyconnman/manager.py b/pyconnman/manager.py | ||
40 | index f6f40a8..03244cc 100644 | ||
41 | --- a/pyconnman/manager.py | ||
42 | +++ b/pyconnman/manager.py | ||
43 | @@ -1,6 +1,6 @@ | ||
44 | from __future__ import unicode_literals | ||
45 | |||
46 | -from interface import ConnInterface | ||
47 | +from .interface import ConnInterface | ||
48 | |||
49 | |||
50 | class ConnManager(ConnInterface): | ||
51 | diff --git a/pyconnman/service.py b/pyconnman/service.py | ||
52 | index bbccced..c6b9241 100644 | ||
53 | --- a/pyconnman/service.py | ||
54 | +++ b/pyconnman/service.py | ||
55 | @@ -1,6 +1,6 @@ | ||
56 | from __future__ import unicode_literals | ||
57 | |||
58 | -from interface import ConnInterface | ||
59 | +from .interface import ConnInterface | ||
60 | |||
61 | |||
62 | class ConnService(ConnInterface): | ||
63 | diff --git a/pyconnman/technology.py b/pyconnman/technology.py | ||
64 | index 4777229..d25bad6 100644 | ||
65 | --- a/pyconnman/technology.py | ||
66 | +++ b/pyconnman/technology.py | ||
67 | @@ -1,6 +1,6 @@ | ||
68 | from __future__ import unicode_literals | ||
69 | |||
70 | -from interface import ConnInterface | ||
71 | +from .interface import ConnInterface | ||
72 | |||
73 | |||
74 | class ConnTechnology(ConnInterface): | ||
diff --git a/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.1.0.bb b/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.1.0.bb deleted file mode 100644 index 32bbe8b80..000000000 --- a/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.1.0.bb +++ /dev/null | |||
@@ -1,9 +0,0 @@ | |||
1 | require python-pyconnman.inc | ||
2 | |||
3 | inherit setuptools3 | ||
4 | |||
5 | SRC_URI_append = " \ | ||
6 | file://0001-Import-local-modules-by-relative-path-for-python3-su.patch \ | ||
7 | " | ||
8 | |||
9 | RDEPENDS_${PN} += "python3-dbus python3-pprint" | ||
diff --git a/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.2.0.bb b/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.2.0.bb new file mode 100644 index 000000000..e0f3fdd75 --- /dev/null +++ b/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.2.0.bb | |||
@@ -0,0 +1,5 @@ | |||
1 | require python-pyconnman.inc | ||
2 | |||
3 | inherit setuptools3 | ||
4 | |||
5 | RDEPENDS_${PN} += "python3-dbus python3-pprint" | ||