summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJeremy Puhlman <jpuhlman@mvista.com>2020-02-14 15:18:26 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commitd4b54a9c612c20c2583410a22cb5d0d54958c5e8 (patch)
tree2867186cc0fc4e3ca1a6e1eb55419410ffa04655 /meta-python
parentbbe7eb6c339611dc6d2686461476637e203fddc4 (diff)
downloadmeta-openembedded-d4b54a9c612c20c2583410a22cb5d0d54958c5e8.tar.gz
pytest-timeout: New package
Adds plugin for pytest to abort tests after a certain time out. Signed-off-by: Jeremy Puhlman <jpuhlman@mvista.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-timeout_1.3.4.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-timeout_1.3.4.bb b/meta-python/recipes-devtools/python/python3-pytest-timeout_1.3.4.bb
new file mode 100644
index 000000000..a359969ed
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-timeout_1.3.4.bb
@@ -0,0 +1,13 @@
1SUMMARY = "py.test plugin to abort hanging tests"
2HOMEPAGE = "https://github.com/pytest-dev/pytest-timeout/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d8048cd156eda3df2e7f111b0ae9ceff"
5
6PYPI_PACKAGE = "pytest-timeout"
7
8SRC_URI[md5sum] = "1594762ae77ed7c6c2727aa8b4aa8bfb"
9SRC_URI[sha256sum] = "80faa19cd245a42b87a51699d640c00d937c02b749052bfca6bae8bdbe12c48e"
10
11inherit pypi setuptools3
12
13RDEPENDS_${PN} = "${PYTHON_PN}-pytest"