diff options
author | Jan Vermaete <jan.vermaete@gmail.com> | 2022-07-24 16:33:26 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-07-26 10:38:42 -0400 |
commit | b7e69905fbc8e4a0e417d360a1702487c9f0936e (patch) | |
tree | e6be34191e2eb234210a671ca624b7da4eb00e9e /meta-python | |
parent | f5645ac7212b92c6ec04ebc82d19dbd223896fd8 (diff) | |
download | meta-openembedded-b7e69905fbc8e4a0e417d360a1702487c9f0936e.tar.gz |
python3-pyzmq: added ptest
And update the summary and description from the github website.
Two tests are failing because cython is not installed.
But this is the same when running pytest under a native Linux system.
Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
3 files changed, 27 insertions, 2 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb index 0721c6c0d..1d2a9952c 100644 --- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb +++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb | |||
@@ -515,6 +515,7 @@ RDEPENDS:packagegroup-meta-python3-ptest = "\ | |||
515 | python3-pyserial-ptest \ | 515 | python3-pyserial-ptest \ |
516 | python3-pytest-lazy-fixture-ptest \ | 516 | python3-pytest-lazy-fixture-ptest \ |
517 | python3-pytoml-ptest \ | 517 | python3-pytoml-ptest \ |
518 | python3-pyzmq-ptest \ | ||
518 | python3-requests-file-ptest \ | 519 | python3-requests-file-ptest \ |
519 | python3-requests-toolbelt-ptest \ | 520 | python3-requests-toolbelt-ptest \ |
520 | python3-scrypt-ptest \ | 521 | python3-scrypt-ptest \ |
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq/run-ptest b/meta-python/recipes-devtools/python/python3-pyzmq/run-ptest new file mode 100644 index 000000000..b63c4de0d --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pyzmq/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | ||
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq_23.2.0.bb b/meta-python/recipes-devtools/python/python3-pyzmq_23.2.0.bb index 37ec9ec84..3471265e4 100644 --- a/meta-python/recipes-devtools/python/python3-pyzmq_23.2.0.bb +++ b/meta-python/recipes-devtools/python/python3-pyzmq_23.2.0.bb | |||
@@ -1,4 +1,5 @@ | |||
1 | SUMMARY = "Pyzmq provides Zero message queue access for the Python language" | 1 | SUMMARY = "PyZMQ: Python bindings for ZMQ" |
2 | DESCRIPTION = "This package contains Python bindings for ZeroMQ. ZMQ is a lightweight and fast messaging implementation." | ||
2 | HOMEPAGE = "http://zeromq.org/bindings:python" | 3 | HOMEPAGE = "http://zeromq.org/bindings:python" |
3 | LICENSE = "BSD-3-Clause & LGPL-3.0-only" | 4 | LICENSE = "BSD-3-Clause & LGPL-3.0-only" |
4 | LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=11c65680f637c3df7f58bbc8d133e96e \ | 5 | LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=11c65680f637c3df7f58bbc8d133e96e \ |
@@ -8,7 +9,11 @@ DEPENDS = "zeromq python3-packaging-native" | |||
8 | SRC_URI += "file://club-rpath-out.patch" | 9 | SRC_URI += "file://club-rpath-out.patch" |
9 | SRC_URI[sha256sum] = "a51f12a8719aad9dcfb55d456022f16b90abc8dde7d3ca93ce3120b40e3fa169" | 10 | SRC_URI[sha256sum] = "a51f12a8719aad9dcfb55d456022f16b90abc8dde7d3ca93ce3120b40e3fa169" |
10 | 11 | ||
11 | inherit pypi pkgconfig python_setuptools_build_meta | 12 | inherit pypi pkgconfig python_setuptools_build_meta ptest |
13 | |||
14 | SRC_URI += " \ | ||
15 | file://run-ptest \ | ||
16 | " | ||
12 | 17 | ||
13 | DEPENDS += "python3-packaging-native" | 18 | DEPENDS += "python3-packaging-native" |
14 | 19 | ||
@@ -25,3 +30,19 @@ do_compile:prepend() { | |||
25 | echo libzmq_extension = False >> ${S}/setup.cfg | 30 | echo libzmq_extension = False >> ${S}/setup.cfg |
26 | echo no_libzmq_extension = True >> ${S}/setup.cfg | 31 | echo no_libzmq_extension = True >> ${S}/setup.cfg |
27 | } | 32 | } |
33 | |||
34 | RDEPENDS:${PN}-ptest += " \ | ||
35 | ${PN}-test \ | ||
36 | " | ||
37 | |||
38 | PACKAGES =+ "\ | ||
39 | ${PN}-test \ | ||
40 | " | ||
41 | |||
42 | FILES:${PN}-test = " \ | ||
43 | ${libdir}/${PYTHON_DIR}/site-packages/*/tests \ | ||
44 | " | ||
45 | do_install_ptest() { | ||
46 | install -d ${D}${PTEST_PATH}/tests | ||
47 | cp -rf ${S}/zmq/tests/* ${D}${PTEST_PATH}/tests/ | ||
48 | } | ||