diff options
author | Sven Ebenfeld <sven.ebenfeld@gmail.com> | 2016-01-22 23:11:43 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-02-01 15:51:15 +0100 |
commit | abc0ec53987b67f07ab64ce4dbd0573cc3d4bd1b (patch) | |
tree | b2cb11abbec350828e5a8607202f8559276a5447 /meta-python | |
parent | 8bebb8ef9c7a056902eef4f66aa85a15a7854014 (diff) | |
download | meta-openembedded-abc0ec53987b67f07ab64ce4dbd0573cc3d4bd1b.tar.gz |
python-dateutil: 1.5 -> 2.4.2 and add python3 recipe
Signed-off-by: Sven Ebenfeld <sven.ebenfeld@gmail.com>
Diffstat (limited to 'meta-python')
4 files changed, 27 insertions, 22 deletions
diff --git a/meta-python/recipes-devtools/python/python-dateutil.inc b/meta-python/recipes-devtools/python/python-dateutil.inc new file mode 100644 index 000000000..b38c44854 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-dateutil.inc | |||
@@ -0,0 +1,23 @@ | |||
1 | SUMMARY = "Extensions to the standard Python datetime module" | ||
2 | DESCRIPTION = "The dateutil module provides powerful extensions to the datetime module available in the Python standard library." | ||
3 | HOMEPAGE = "https://dateutil.readthedocs.org" | ||
4 | SECTION = "devel/python" | ||
5 | LICENSE = "BSD-3-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=51430b33c900f45f999c459ee29ca493" | ||
7 | PR = "r0" | ||
8 | |||
9 | SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz" | ||
10 | SRC_URI[md5sum] = "4ef68e1c485b09e9f034e10473e5add2" | ||
11 | SRC_URI[sha256sum] = "3e95445c1db500a344079a47b171c45ef18f57d188dffdb0e4165c71bea8eb3d" | ||
12 | |||
13 | SRCNAME = "python-dateutil" | ||
14 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
15 | |||
16 | PACKAGES =+ "${PN}-zoneinfo" | ||
17 | FILES_${PN}-zoneinfo = "${libdir}/${PYTHON_DIR}/site-packages/dateutil/zoneinfo" | ||
18 | |||
19 | RDEPENDS_${PN} = "\ | ||
20 | ${PYTHON_PN}-core \ | ||
21 | ${PYTHON_PN}-datetime \ | ||
22 | ${PYTHON_PN}-six \ | ||
23 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-dateutil_1.5.bb b/meta-python/recipes-devtools/python/python-dateutil_1.5.bb deleted file mode 100644 index 37f19a839..000000000 --- a/meta-python/recipes-devtools/python/python-dateutil_1.5.bb +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | SUMMARY = "Extensions to the standard Python date/time support" | ||
2 | HOMEPAGE = "http://labix.org/python-dateutil" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "PSF" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d82268718c68bda0b091006ec6e583c6" | ||
6 | SRCNAME = "${BPN}" | ||
7 | |||
8 | SRC_URI = "http://labix.org/download/python-dateutil/${SRCNAME}-${PV}.tar.gz" | ||
9 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
10 | |||
11 | inherit setuptools | ||
12 | |||
13 | PACKAGES =+ "${PN}-zoneinfo" | ||
14 | FILES_${PN}-zoneinfo = "${libdir}/${PYTHON_DIR}/site-packages/dateutil/zoneinfo" | ||
15 | |||
16 | RDEPENDS_${PN} = "\ | ||
17 | python-core \ | ||
18 | python-datetime \ | ||
19 | " | ||
20 | |||
21 | SRC_URI[md5sum] = "35f3732db3f2cc4afdc68a8533b60a52" | ||
22 | SRC_URI[sha256sum] = "c08aca7d85f8f8eed61e83b3423b829262c596a9a78f7ca3de0bcee2217d0e3b" | ||
diff --git a/meta-python/recipes-devtools/python/python-dateutil_2.4.2.bb b/meta-python/recipes-devtools/python/python-dateutil_2.4.2.bb new file mode 100644 index 000000000..12ae4c311 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-dateutil_2.4.2.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools | ||
2 | require python-dateutil.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-dateutil_2.4.2.bb b/meta-python/recipes-devtools/python/python3-dateutil_2.4.2.bb new file mode 100644 index 000000000..1d2baf55c --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-dateutil_2.4.2.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-dateutil.inc | ||