summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-05-15 14:39:39 -0400
committerKhem Raj <raj.khem@gmail.com>2020-05-19 17:14:08 -0700
commita8f3c00d8d113b46a49584682e10435157d516ca (patch)
tree1840f29c2e153f402d679e375c4c22f7d4e69ef5 /meta-python
parenta011a5fc045aba99378c54e6d2a58f2f7c22b416 (diff)
downloadmeta-openembedded-a8f3c00d8d113b46a49584682e10435157d516ca.tar.gz
python3-pycryptodome(x): moved to OE-Core, remove from meta-python
Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pycryptodome.inc29
-rw-r--r--meta-python/recipes-devtools/python/python3-pycryptodome_3.9.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pycryptodomex_3.9.4.bb10
3 files changed, 0 insertions, 41 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycryptodome.inc b/meta-python/recipes-devtools/python/python-pycryptodome.inc
deleted file mode 100644
index 63b4a4abb..000000000
--- a/meta-python/recipes-devtools/python/python-pycryptodome.inc
+++ /dev/null
@@ -1,29 +0,0 @@
1SUMMARY = "Cryptographic library for Python"
2DESCRIPTION = "PyCryptodome is a self-contained Python package of low-level\
3 cryptographic primitives."
4HOMEPAGE = "http://www.pycryptodome.org"
5LICENSE = "PD & BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=6dc0e2a13d2f25d6f123c434b761faba"
7
8SRC_URI[md5sum] = "f990716b49add7b14ea8b8a961fb3746"
9SRC_URI[sha256sum] = "a168e73879619b467072509a223282a02c8047d932a48b74fbd498f27224aa04"
10
11inherit pypi
12
13RDEPENDS_${PN} += " \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-math \
16"
17
18RDEPENDS_${PN}-tests += " \
19 ${PYTHON_PN}-unittest \
20"
21
22PACKAGES =+ "${PN}-tests"
23
24FILES_${PN}-tests = " \
25 ${PYTHON_SITEPACKAGES_DIR}/Crypto/SelfTest/ \
26 ${PYTHON_SITEPACKAGES_DIR}/Crypto/SelfTest/__pycache__/ \
27"
28
29BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pycryptodome_3.9.4.bb b/meta-python/recipes-devtools/python/python3-pycryptodome_3.9.4.bb
deleted file mode 100644
index 0c062dddf..000000000
--- a/meta-python/recipes-devtools/python/python3-pycryptodome_3.9.4.bb
+++ /dev/null
@@ -1,2 +0,0 @@
1require python-pycryptodome.inc
2inherit setuptools3
diff --git a/meta-python/recipes-devtools/python/python3-pycryptodomex_3.9.4.bb b/meta-python/recipes-devtools/python/python3-pycryptodomex_3.9.4.bb
deleted file mode 100644
index e41c14b14..000000000
--- a/meta-python/recipes-devtools/python/python3-pycryptodomex_3.9.4.bb
+++ /dev/null
@@ -1,10 +0,0 @@
1require python-pycryptodome.inc
2inherit setuptools3
3
4SRC_URI[md5sum] = "46ba513d95b6e323734074d960a7d57b"
5SRC_URI[sha256sum] = "22d970cee5c096b9123415e183ae03702b2cd4d3ba3f0ced25c4e1aba3967167"
6
7FILES_${PN}-tests = " \
8 ${PYTHON_SITEPACKAGES_DIR}/Cryptodome/SelfTest/ \
9 ${PYTHON_SITEPACKAGES_DIR}/Cryptodome/SelfTest/__pycache__/ \
10"