summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-03-15 08:55:58 -0700
committertgamblin <trevor.gamblin@windriver.com>2022-03-16 09:25:28 -0400
commit888570237a4a9bdd440ce966d50ed96fd07a4a59 (patch)
treeac57674f04595d1466c5640b0474bfbac44c0fc8 /meta-python
parent996bfa2f914aeaa6f6251b5b52b766b12773c6e8 (diff)
downloadmeta-openembedded-888570237a4a9bdd440ce966d50ed96fd07a4a59.tar.gz
python3-pytz: move to oe-core
This recipe has been moved to oe-core in support of python3-cryptography. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: tgamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytz/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-pytz_2021.3.bb35
2 files changed, 0 insertions, 38 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytz/run-ptest b/meta-python/recipes-devtools/python/python3-pytz/run-ptest
deleted file mode 100644
index b63c4de0d..000000000
--- a/meta-python/recipes-devtools/python/python3-pytz/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-pytz_2021.3.bb b/meta-python/recipes-devtools/python/python3-pytz_2021.3.bb
deleted file mode 100644
index 119342a4b..000000000
--- a/meta-python/recipes-devtools/python/python3-pytz_2021.3.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1SUMMARY = "World timezone definitions, modern and historical"
2HOMEPAGE = "http://pythonhosted.org/pytz"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999"
5
6inherit pypi setuptools3 ptest
7
8SRC_URI[sha256sum] = "acad2d8b20a1af07d4e4c9d2e9285c5ed9104354062f275f3fcd88dcef4f1326"
9
10RDEPENDS:${PN}:class-target += "\
11 ${PYTHON_PN}-datetime \
12 ${PYTHON_PN}-doctest \
13 ${PYTHON_PN}-io \
14 ${PYTHON_PN}-pickle \
15 ${PYTHON_PN}-pprint \
16 ${PYTHON_PN}-threading \
17"
18
19BBCLASSEXTEND = "native nativesdk"
20
21SRC_URI += " \
22 file://run-ptest \
23"
24
25RDEPENDS:${PN}-ptest += " \
26 ${PYTHON_PN}-pytest \
27"
28
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}/pytz
31 install -d ${D}${PTEST_PATH}/pytz/tests
32 cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
33 cp -f ${S}/README.rst ${D}${PTEST_PATH}/
34
35}