diff options
author | Tim Orling <ticotimo@gmail.com> | 2022-02-27 12:09:09 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-03-01 09:06:56 -0800 |
commit | 870a9bd263c51c47f718e2eb9b456a9d345c7330 (patch) | |
tree | d01ea07dcb355b62ec53e50acb32b04cd369013e /meta-python | |
parent | 2481bc359fd44635f41131675b1a93541213ec49 (diff) | |
download | meta-openembedded-870a9bd263c51c47f718e2eb9b456a9d345c7330.tar.gz |
python3-systemd: patch to use setuptools
setup.py bdist_wheel does not work with ditutils (which is deprecated
anyway). Add a patch to switch to setuptools to allow wheel to be built.
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch | 30 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-systemd_234.bb | 5 |
2 files changed, 34 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch b/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch new file mode 100644 index 000000000..b3180f29f --- /dev/null +++ b/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From a681a79472df85cdc8c052bc61fb8b9e7b9a6495 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tim Orling <tim.orling@konsulko.com> | ||
3 | Date: Sun, 27 Feb 2022 11:50:36 -0800 | ||
4 | Subject: [PATCH] setup.py: switch from distutils to setuptools | ||
5 | |||
6 | In Python 3.10, distutils is deprecated and slated for removal in Python | ||
7 | 3.12. It also prevents 'setup.py bdist_wheel' from building a wheel. | ||
8 | |||
9 | Upstream-Status: Submitted | ||
10 | [https://github.com/systemd/python-systemd/pull/103] | ||
11 | |||
12 | Signed-off-by: Tim Orling <tim.orling@konsulko.com> | ||
13 | --- | ||
14 | setup.py | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/setup.py b/setup.py | ||
18 | index 099819b..fe9c03a 100644 | ||
19 | --- a/setup.py | ||
20 | +++ b/setup.py | ||
21 | @@ -1,5 +1,5 @@ | ||
22 | import sys, os | ||
23 | -from distutils.core import setup, Extension | ||
24 | +from setuptools import setup, Extension | ||
25 | from subprocess import Popen, PIPE, check_output | ||
26 | |||
27 | def call(*cmd): | ||
28 | -- | ||
29 | 2.30.2 | ||
30 | |||
diff --git a/meta-python/recipes-devtools/python/python3-systemd_234.bb b/meta-python/recipes-devtools/python/python3-systemd_234.bb index cbc9f44bc..1aecb375b 100644 --- a/meta-python/recipes-devtools/python/python3-systemd_234.bb +++ b/meta-python/recipes-devtools/python/python3-systemd_234.bb | |||
@@ -15,6 +15,9 @@ SRC_URI[sha256sum] = "fd0e44bf70eadae45aadc292cb0a7eb5b0b6372cd1b391228047d33895 | |||
15 | # allow for common patches for python- and python3-systemd | 15 | # allow for common patches for python- and python3-systemd |
16 | FILESEXTRAPATHS:prepend := "${THISDIR}/python-systemd:" | 16 | FILESEXTRAPATHS:prepend := "${THISDIR}/python-systemd:" |
17 | 17 | ||
18 | SRC_URI += "file://endian.patch" | 18 | SRC_URI += " \ |
19 | file://endian.patch \ | ||
20 | file://0002-setup.py-switch-from-distutils-to-setuptools.patch \ | ||
21 | " | ||
19 | 22 | ||
20 | SRC_URI:append:libc-musl = " file://0001-Provide-implementation-of-strndupa-for-musl.patch" | 23 | SRC_URI:append:libc-musl = " file://0001-Provide-implementation-of-strndupa-for-musl.patch" |