diff options
author | Archana Polampalli <archana.polampalli@windriver.com> | 2023-08-23 09:47:08 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-08-26 17:32:44 -0700 |
commit | 7bfbf9eee8b45ad294d1a79523e16bba5fab7a11 (patch) | |
tree | 907f440c4b53cadd5ebf864911fbbe3fb2e2a7ae /meta-python | |
parent | 75c2ce3c31a622739b742d32c1183a491ad72a46 (diff) | |
download | meta-openembedded-7bfbf9eee8b45ad294d1a79523e16bba5fab7a11.tar.gz |
python3-pyroute2: fix ptest failure
The ptest fails after python3-pyroute2 is upgraded to 0.7.9.
Fixes:
=================================================
tests/test_unit/test_iproute_match/test_match.py:10: in <module>
with open('test_unit/test_iproute_match/links.dump', 'r') as f:
E FileNotFoundError: [Errno 2] No such file or directory:
'test_unit/test_iproute_match/links.dump'
with open(sample, 'r') as buf:
E FileNotFoundError: [Errno 2] No such file or directory:
'test_unit/test_nlmsg/gre_01.dump'
=================================================
root@qemux86-64:~# ptest-runner python3-pyroute2
START: ptest-runner
2023-08-22T10:31
BEGIN: /usr/lib/python3-pyroute2/ptest
============================= test session starts ==============================
platform linux -- Python 3.11.4, pytest-7.4.0, pluggy-1.2.0
rootdir: /usr/lib/python3-pyroute2/ptest
collected 103 items
PASS: tests/test_unit/test_addr_pool.py::test_alloc_aligned
PASS: tests/test_unit/test_addr_pool.py::test_alloc_odd
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pyroute2_0.7.9.bb | 2 |
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyroute2_0.7.9.bb b/meta-python/recipes-devtools/python/python3-pyroute2_0.7.9.bb index 263acd06c..39fbd1a00 100644 --- a/meta-python/recipes-devtools/python/python3-pyroute2_0.7.9.bb +++ b/meta-python/recipes-devtools/python/python3-pyroute2_0.7.9.bb | |||
@@ -35,4 +35,6 @@ RDEPENDS:${PN}-ptest += " \ | |||
35 | do_install_ptest() { | 35 | do_install_ptest() { |
36 | install -d ${D}${PTEST_PATH}/tests | 36 | install -d ${D}${PTEST_PATH}/tests |
37 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | 37 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
38 | sed -e "s|'test_unit|'tests/test_unit|g" -i ${D}${PTEST_PATH}/tests/test_unit/test_nlmsg/test_marshal.py \ | ||
39 | ${D}${PTEST_PATH}/tests/test_unit/test_iproute_match/test_match.py | ||
38 | } | 40 | } |