diff options
author | Li xin <lixin.fnst@cn.fujitsu.com> | 2016-01-04 13:12:37 +0300 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-01-27 12:43:57 +0100 |
commit | 6b4cee97597c0587cc83b787f036dbfa181915f2 (patch) | |
tree | efcff99fb8cb6b624ac14b2b4a5cd76ff9168a38 /meta-python | |
parent | 72210ea4769d9f58477931d78c4e506ef6ad776b (diff) | |
download | meta-openembedded-6b4cee97597c0587cc83b787f036dbfa181915f2.tar.gz |
python-six: Error fix for recipes depend on python-six
If you bitbake recipes which depends on python-six such as
python-cryptography. And also your network is not very well.
Error will occur as following:
Download error on https://pypi.python.org/simple/six/:
[Errno -5] No address associated with hostname -- Some packages may not be found!
Couldn't find index page for 'six' (maybe misspelled?)
No local packages or download links found for six
So add do_compile_append() to fix it.
Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-six_1.9.0.bb | 8 |
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-six_1.9.0.bb b/meta-python/recipes-devtools/python/python-six_1.9.0.bb index aa96dc9a8..c6575f386 100644 --- a/meta-python/recipes-devtools/python/python-six_1.9.0.bb +++ b/meta-python/recipes-devtools/python/python-six_1.9.0.bb | |||
@@ -6,3 +6,11 @@ SRC_URI[md5sum] = "476881ef4012262dfc8adc645ee786c4" | |||
6 | SRC_URI[sha256sum] = "e24052411fc4fbd1f672635537c3fc2330d9481b18c0317695b46259512c91d5" | 6 | SRC_URI[sha256sum] = "e24052411fc4fbd1f672635537c3fc2330d9481b18c0317695b46259512c91d5" |
7 | 7 | ||
8 | inherit pypi | 8 | inherit pypi |
9 | |||
10 | do_compile_append() { | ||
11 | export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} | ||
12 | ${PYTHON} setup.py -q bdist_egg --dist-dir ./ | ||
13 | } | ||
14 | do_install_append() { | ||
15 | install -m 0644 ${S}/*.egg ${D}/${PYTHON_SITEPACKAGES_DIR}/ | ||
16 | } | ||