diff options
author | Daniel Dragomir <daniel.dragomir@windriver.com> | 2018-03-08 18:54:58 +0200 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-03-16 19:27:54 -0700 |
commit | 492c7efc36ec94dc6a05e65df5a6a302f9283314 (patch) | |
tree | 01ce2e34a56937ffc0c166ab4cf9af250ef7ba82 /meta-python | |
parent | d0239ec5cd18fea7380bb94b004ace2789f9f3ff (diff) | |
download | meta-openembedded-492c7efc36ec94dc6a05e65df5a6a302f9283314.tar.gz |
python-robotframework: add recipe for 3.0.2 version
Robot Framework is a generic open source test automation framework
for acceptance testing and acceptance test-driven development (ATDD).
It has easy-to-use tabular test data syntax and it utilizes the
keyword-driven testing approach. Its testing capabilities can be
extended by test libraries implemented either with Python or Java,
and users can create new higher-level keywords from existing ones
using the same syntax that is used for creating test cases.
Signed-off-by: Daniel Dragomir <daniel.dragomir@windriver.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
3 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-robotframework.inc b/meta-python/recipes-devtools/python/python-robotframework.inc new file mode 100644 index 000000000..cc20d6477 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-robotframework.inc | |||
@@ -0,0 +1,15 @@ | |||
1 | SUMMARY = "A Python generic test automation framework" | ||
2 | DESCRIPTION = "Generic open source test atomation framework for acceptance\ | ||
3 | testing and acceptance test-driven development (ATDD). It has easy-to-use\ | ||
4 | tabular test data syntax and it utilizes the keyword-driven testing approach.\ | ||
5 | Its testing capabilities can be extended by test libraries implemented either\ | ||
6 | with Python or Java, and users can create new higher-level keywords from\ | ||
7 | existing ones using the same syntax that is used for creating test cases." | ||
8 | HOMEPAGE = "http://robotframework.org" | ||
9 | LICENSE = "Apache-2.0" | ||
10 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
11 | |||
12 | inherit pypi | ||
13 | |||
14 | SRC_URI[md5sum] = "ea49a54b9d7e38302712194e85c37eaa" | ||
15 | SRC_URI[sha256sum] = "2018f233568227f9af8c366f93e243a157b742f3baf5b649ecc9750ac0ee1ff7" | ||
diff --git a/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb b/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb new file mode 100644 index 000000000..16eaa78cd --- /dev/null +++ b/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools | ||
2 | require python-robotframework.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-robotframework_3.0.2.bb b/meta-python/recipes-devtools/python/python3-robotframework_3.0.2.bb new file mode 100644 index 000000000..8f613c386 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-robotframework_3.0.2.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-robotframework.inc | ||