diff options
author | Derek Straka <derek@asterius.io> | 2017-03-02 11:24:24 -0500 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-03-04 12:38:56 +0100 |
commit | 32b0092f6f6bb6687633e24ab44cf0f2ab73c810 (patch) | |
tree | dca9af898454cdfe130ef1633dcfde7099a3d447 /meta-python | |
parent | 8173c31a017bf40c44e9de8ff4288b100b48ab74 (diff) | |
download | meta-openembedded-32b0092f6f6bb6687633e24ab44cf0f2ab73c810.tar.gz |
python-simplejson: relocate to meta-python and add a python3 version
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
3 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-simplejson.inc b/meta-python/recipes-devtools/python/python-simplejson.inc new file mode 100644 index 000000000..2eed19965 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-simplejson.inc | |||
@@ -0,0 +1,17 @@ | |||
1 | SUMMARY = "Simple, fast, extensible JSON encoder/decoder for Python" | ||
2 | HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson" | ||
3 | |||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e" | ||
6 | |||
7 | SRC_URI[md5sum] = "426a9631d22851a7a970b1a677368b15" | ||
8 | SRC_URI[sha256sum] = "953be622e88323c6f43fad61ffd05bebe73b9fd9863a46d68b052d2aa7d71ce2" | ||
9 | |||
10 | inherit pypi | ||
11 | |||
12 | RDEPENDS_${PN} += "\ | ||
13 | ${PYTHON_PN}-re \ | ||
14 | ${PYTHON_PN}-io \ | ||
15 | ${PYTHON_PN}-netserver \ | ||
16 | ${PYTHON_PN}-numbers \ | ||
17 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb b/meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb new file mode 100644 index 000000000..e33edfeba --- /dev/null +++ b/meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools | ||
2 | require python-simplejson.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb b/meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb new file mode 100644 index 000000000..d44bc1526 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb | |||
@@ -0,0 +1,7 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-simplejson.inc | ||
3 | |||
4 | # Requires _pydecimal which is in misc | ||
5 | RDEPENDS_${PN} += " \ | ||
6 | ${PYTHON_PN}-misc \ | ||
7 | " | ||