summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-02-11 10:15:54 -0500
committerArmin Kuster <akuster808@gmail.com>2018-02-23 20:27:01 -0800
commite0ffc0c29a275c117df08d3d67226abdafd02b1b (patch)
tree462bf83f861459343d610338e8595c5f4bef9f10 /meta-python
parent28d37e975f96cba852a6337322c58a292ca6c483 (diff)
downloadmeta-openembedded-e0ffc0c29a275c117df08d3d67226abdafd02b1b.tar.gz
python-pycryptodome: update to version 3.4.11
Update RDEPENDS to work on minimal python distribution Create a test package for unit tests Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pycryptodome.inc20
-rw-r--r--meta-python/recipes-devtools/python/python-pycryptodome_3.4.11.bb (renamed from meta-python/recipes-devtools/python/python-pycryptodome_3.4.8.bb)0
-rw-r--r--meta-python/recipes-devtools/python/python3-pycryptodome_3.4.11.bb (renamed from meta-python/recipes-devtools/python/python3-pycryptodome_3.4.8.bb)0
3 files changed, 18 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycryptodome.inc b/meta-python/recipes-devtools/python/python-pycryptodome.inc
index 1efe1eb27..c4969f966 100644
--- a/meta-python/recipes-devtools/python/python-pycryptodome.inc
+++ b/meta-python/recipes-devtools/python/python-pycryptodome.inc
@@ -5,9 +5,25 @@ HOMEPAGE = "http://www.pycryptodome.org"
5LICENSE = "PD & BSD-2-Clause" 5LICENSE = "PD & BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=775fe77831c03bf82f35abc0e230d4c1" 6LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=775fe77831c03bf82f35abc0e230d4c1"
7 7
8SRC_URI[md5sum] = "030c40da6377bbc82deef8e884fa22cd" 8SRC_URI[md5sum] = "a2587b6381b0ef4eb960cea1e7507d04"
9SRC_URI[sha256sum] = "ede7f1f44b0895feb8ddbf882d1a7eb504deb3fa34fcc4860d6065c25cbdf175" 9SRC_URI[sha256sum] = "c5dd29e9f1b733e74311bf95d0e544e91bd1d14bc0366e8f443562d8d9920b7d"
10 10
11inherit pypi 11inherit pypi
12 12
13RDEPENDS_${PN} += " \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-math \
16"
17
18RDEPENDS_${PN}-tests += " \
19 ${PYTHON_PN}-unittest \
20"
21
22PACKAGES =+ "${PN}-tests"
23
24FILES_${PN}-tests += " \
25 ${PYTHON_SITEPACKAGES_DIR}/Crypto/SelfTest/ \
26 ${PYTHON_SITEPACKAGES_DIR}/Crypto/SelfTest/__pycache__/ \
27"
28
13BBCLASSEXTEND = "native nativesdk" 29BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pycryptodome_3.4.8.bb b/meta-python/recipes-devtools/python/python-pycryptodome_3.4.11.bb
index c7701eb9f..c7701eb9f 100644
--- a/meta-python/recipes-devtools/python/python-pycryptodome_3.4.8.bb
+++ b/meta-python/recipes-devtools/python/python-pycryptodome_3.4.11.bb
diff --git a/meta-python/recipes-devtools/python/python3-pycryptodome_3.4.8.bb b/meta-python/recipes-devtools/python/python3-pycryptodome_3.4.11.bb
index 0c062dddf..0c062dddf 100644
--- a/meta-python/recipes-devtools/python/python3-pycryptodome_3.4.8.bb
+++ b/meta-python/recipes-devtools/python/python3-pycryptodome_3.4.11.bb