summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-21 11:20:33 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-26 17:28:11 -0800
commitdf6f7688e8b8369ddeb95e85ac05b8393916d095 (patch)
tree967c0eca2e8ae037d49d097036b0482b196d2f7f /meta-python
parent79080374c81fdcf404db9bc24e4a0b1455042fee (diff)
downloadmeta-openembedded-df6f7688e8b8369ddeb95e85ac05b8393916d095.tar.gz
Remove deprecated python3-selectors from the RDEPENDS
The python3-selectors package was removed as part of the migration to the json manifest file. The functionality is now part of core Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-asn1crypto_0.24.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-ntplib_0.3.3.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-pyserial_3.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pysocks_1.6.8.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb1
9 files changed, 1 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-asn1crypto_0.24.0.bb b/meta-python/recipes-devtools/python/python3-asn1crypto_0.24.0.bb
index 9d9837228..cfbe57520 100644
--- a/meta-python/recipes-devtools/python/python3-asn1crypto_0.24.0.bb
+++ b/meta-python/recipes-devtools/python/python3-asn1crypto_0.24.0.bb
@@ -2,6 +2,5 @@ inherit setuptools3
2require python-asn1crypto.inc 2require python-asn1crypto.inc
3 3
4RDEPENDS_${PN}_class-target += " \ 4RDEPENDS_${PN}_class-target += " \
5 ${PYTHON_PN}-selectors \
6 ${PYTHON_PN}-shell \ 5 ${PYTHON_PN}-shell \
7" 6"
diff --git a/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb b/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb
index e28389ef1..091eb368a 100644
--- a/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb
+++ b/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb
@@ -4,5 +4,4 @@ require python-dnspython.inc
4# Requires _pydecimal.py which is in misc 4# Requires _pydecimal.py which is in misc
5RDEPENDS_${PN} += " \ 5RDEPENDS_${PN} += " \
6 ${PYTHON_PN}-misc \ 6 ${PYTHON_PN}-misc \
7 ${PYTHON_PN}-selectors \
8" 7"
diff --git a/meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb b/meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb
index bd2bcb3de..70813bf34 100644
--- a/meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb
@@ -1,4 +1,2 @@
1inherit setuptools3 1inherit setuptools3
2require python-hyperlink.inc 2require python-hyperlink.inc
3
4RDEPENDS_${PN} += "${PYTHON_PN}-selectors"
diff --git a/meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb b/meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb
index be55770dd..30416a4ff 100644
--- a/meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb
+++ b/meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb
@@ -1,6 +1,2 @@
1require python-netaddr.inc 1require python-netaddr.inc
2inherit setuptools3 2inherit setuptools3
3
4RDEPENDS_${PN} += " \
5 ${PYTHON_PN}-selectors \
6"
diff --git a/meta-python/recipes-devtools/python/python3-ntplib_0.3.3.bb b/meta-python/recipes-devtools/python/python3-ntplib_0.3.3.bb
index 997b0cad7..93df83ad3 100644
--- a/meta-python/recipes-devtools/python/python3-ntplib_0.3.3.bb
+++ b/meta-python/recipes-devtools/python/python3-ntplib_0.3.3.bb
@@ -11,4 +11,4 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
11 11
12inherit setuptools3 python3native pypi 12inherit setuptools3 python3native pypi
13 13
14RDEPENDS_${PN} += "${PYTHON_PN}-datetime ${PYTHON_PN}-selectors" 14RDEPENDS_${PN} += "${PYTHON_PN}-datetime"
diff --git a/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb b/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb
index 55b0314a0..e6e972617 100644
--- a/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb
@@ -4,6 +4,5 @@ require python-pymongo.inc
4# Requires _pydecimal which is in misc 4# Requires _pydecimal which is in misc
5RDEPENDS_${PYTHON_PN}-bson += " \ 5RDEPENDS_${PYTHON_PN}-bson += " \
6 ${PYTHON_PN}-misc \ 6 ${PYTHON_PN}-misc \
7 ${PYTHON_PN}-selectors \
8 ${PYTHON_PN}-subprocess \ 7 ${PYTHON_PN}-subprocess \
9" 8"
diff --git a/meta-python/recipes-devtools/python/python3-pyserial_3.4.bb b/meta-python/recipes-devtools/python/python3-pyserial_3.4.bb
index 6807b9510..17ed3f8bc 100644
--- a/meta-python/recipes-devtools/python/python3-pyserial_3.4.bb
+++ b/meta-python/recipes-devtools/python/python3-pyserial_3.4.bb
@@ -5,5 +5,3 @@ do_install_append() {
5 rm -f ${D}${bindir}/miniterm.py 5 rm -f ${D}${bindir}/miniterm.py
6 rmdir ${D}${bindir} 6 rmdir ${D}${bindir}
7} 7}
8
9RDEPENDS_${PN} += "${PYTHON_PN}-selectors"
diff --git a/meta-python/recipes-devtools/python/python3-pysocks_1.6.8.bb b/meta-python/recipes-devtools/python/python3-pysocks_1.6.8.bb
index e5f00e871..bbda05a51 100644
--- a/meta-python/recipes-devtools/python/python3-pysocks_1.6.8.bb
+++ b/meta-python/recipes-devtools/python/python3-pysocks_1.6.8.bb
@@ -3,5 +3,4 @@ require python-pysocks.inc
3 3
4RDEPENDS_${PN}_class-target += "\ 4RDEPENDS_${PN}_class-target += "\
5 ${PYTHON_PN}-netclient \ 5 ${PYTHON_PN}-netclient \
6 ${PYTHON_PN}-selectors \
7" 6"
diff --git a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
index b8dc1741b..8ad1c1747 100644
--- a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
+++ b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
@@ -4,5 +4,4 @@ require python-whoosh.inc
4# Requires _pydecimal.py which is in misc 4# Requires _pydecimal.py which is in misc
5RDEPENDS_${PN} += " \ 5RDEPENDS_${PN} += " \
6 ${PYTHON_PN}-misc \ 6 ${PYTHON_PN}-misc \
7 ${PYTHON_PN}-selectors \
8" 7"