summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorSven Ebenfeld <sven.ebenfeld@gmail.com>2016-01-22 23:56:32 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-01 15:51:17 +0100
commitd5bb0a142052ffd51bf3281ba0997ad081f81086 (patch)
tree23351fe66d6a799173327c822279c95840be0824 /meta-python
parent9a5ab2a080258ed6b097eaa2e025a1dbf2c3d6fa (diff)
downloadmeta-openembedded-d5bb0a142052ffd51bf3281ba0997ad081f81086.tar.gz
python3-tornado: add recipe
Signed-off-by: Sven Ebenfeld <sven.ebenfeld@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-tornado.inc24
-rw-r--r--meta-python/recipes-devtools/python/python-tornado_4.3.bb37
-rw-r--r--meta-python/recipes-devtools/python/python3-tornado_4.3.bb2
3 files changed, 29 insertions, 34 deletions
diff --git a/meta-python/recipes-devtools/python/python-tornado.inc b/meta-python/recipes-devtools/python/python-tornado.inc
new file mode 100644
index 000000000..679b7ba03
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-tornado.inc
@@ -0,0 +1,24 @@
1SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed."
2DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \
3By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \
4polling, WebSockets, and other applications that require a long-lived connection to each user."
5HOMEPAGE = "http://www.tornadoweb.org/en/stable/"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://setup.py;startline=2;endline=15;md5=5ab7571a79ad62d0ca7aea308bac7560"
8
9SRC_URI[md5sum] = "d13a99dc0b60ba69f5f8ec1235e5b232"
10SRC_URI[sha256sum] = "c9c2d32593d16eedf2cec1b6a41893626a2649b40b21ca9c4cac4243bde2efbf"
11
12RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-numbers ${PYTHON_PN}-email ${PYTHON_PN}-subprocess \
13 ${PYTHON_PN}-pkgutil ${PYTHON_PN}-html ${PYTHON_PN}-json ${PYTHON_PN}-certifi"
14
15RDEPENDS_${PN}-test += "${PN} ${PYTHON_PN}-unittest"
16
17PACKAGES =+ "\
18 ${PN}-test \
19"
20
21FILES_${PN}-test = " \
22 ${libdir}/${PYTHON_DIR}/site-packages/${SRCNAME}/test \
23 ${libdir}/${PYTHON_DIR}/site-packages/${SRCNAME}/testing.py* \
24"
diff --git a/meta-python/recipes-devtools/python/python-tornado_4.3.bb b/meta-python/recipes-devtools/python/python-tornado_4.3.bb
index c107d6c45..5bbad50a9 100644
--- a/meta-python/recipes-devtools/python/python-tornado_4.3.bb
+++ b/meta-python/recipes-devtools/python/python-tornado_4.3.bb
@@ -1,34 +1,3 @@
1SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed." 1inherit pypi
2DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \ 2require python-tornado.inc
3By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \ 3RDEPENDS_${PN} += "${PYTHON_PN}-backports-ssl"
4polling, WebSockets, and other applications that require a long-lived connection to each user."
5HOMEPAGE = "http://www.tornadoweb.org/en/stable/"
6
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://PKG-INFO;md5=65b6c818261e415f48f5463a232ad195"
9
10SRCNAME = "tornado"
11
12SRC_URI = " \
13 https://pypi.python.org/packages/source/t/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
14"
15SRC_URI[md5sum] = "d13a99dc0b60ba69f5f8ec1235e5b232"
16SRC_URI[sha256sum] = "c9c2d32593d16eedf2cec1b6a41893626a2649b40b21ca9c4cac4243bde2efbf"
17
18inherit setuptools
19
20RDEPENDS_${PN} += "python-compression python-numbers python-email python-subprocess \
21 python-pkgutil python-html python-json python-backports-ssl python-certifi"
22
23RDEPENDS_${PN}-test += "${PN} python-unittest"
24
25S = "${WORKDIR}/${SRCNAME}-${PV}"
26
27PACKAGES =+ "\
28 ${PN}-test \
29"
30
31FILES_${PN}-test = " \
32 ${libdir}/${PYTHON_DIR}/site-packages/${SRCNAME}/test \
33 ${libdir}/${PYTHON_DIR}/site-packages/${SRCNAME}/testing.py* \
34"
diff --git a/meta-python/recipes-devtools/python/python3-tornado_4.3.bb b/meta-python/recipes-devtools/python/python3-tornado_4.3.bb
new file mode 100644
index 000000000..21a4300f2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-tornado_4.3.bb
@@ -0,0 +1,2 @@
1inherit pypi3
2require python-tornado.inc