summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2015-12-15 10:28:45 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-04 14:53:59 +0100
commit524f332a5db28e489737a6fff1154755cfdb0743 (patch)
treecc0045948c196ed2c217f7441ea4e16c6bbf245c /meta-python
parent50bd6e1a9e141c294d9468a68b5067633371879a (diff)
downloadmeta-openembedded-524f332a5db28e489737a6fff1154755cfdb0743.tar.gz
python-tornado: move old version recipe from meta-oe to meta-python
Move old version recipe of python-tornado from meta-oe to meta-python that there is a higher version in meta-python already. And rename from _git to exact version _2.2.1. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-tornado/0001-disable-AI_ADDRCONFIG-flag.patch32
-rw-r--r--meta-python/recipes-devtools/python/python-tornado_2.2.1.bb16
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-tornado/0001-disable-AI_ADDRCONFIG-flag.patch b/meta-python/recipes-devtools/python/python-tornado/0001-disable-AI_ADDRCONFIG-flag.patch
new file mode 100644
index 000000000..0b0d471a4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-tornado/0001-disable-AI_ADDRCONFIG-flag.patch
@@ -0,0 +1,32 @@
1From d7fb0a6ef3f3cbdfc1f21f5a67d54fa9d2c1e183 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 2 Nov 2011 11:07:24 +0100
4Subject: [PATCH] disable AI_ADDRCONFIG flag
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7
8Upstream-Status: unknown
9---
10 tornado/netutil.py | 6 ------
11 1 files changed, 0 insertions(+), 6 deletions(-)
12
13diff --git a/tornado/netutil.py b/tornado/netutil.py
14index cfff0ba..c181f24 100644
15--- a/tornado/netutil.py
16+++ b/tornado/netutil.py
17@@ -238,12 +238,6 @@ def bind_sockets(port, address=None, family=socket.AF_UNSPEC, backlog=128):
18 if address == "":
19 address = None
20 flags = socket.AI_PASSIVE
21- if hasattr(socket, "AI_ADDRCONFIG"):
22- # AI_ADDRCONFIG ensures that we only try to bind on ipv6
23- # if the system is configured for it, but the flag doesn't
24- # exist on some platforms (specifically WinXP, although
25- # newer versions of windows have it)
26- flags |= socket.AI_ADDRCONFIG
27 for res in set(socket.getaddrinfo(address, port, family, socket.SOCK_STREAM,
28 0, flags):
29 af, socktype, proto, canonname, sockaddr = res
30--
311.7.2.5
32
diff --git a/meta-python/recipes-devtools/python/python-tornado_2.2.1.bb b/meta-python/recipes-devtools/python/python-tornado_2.2.1.bb
new file mode 100644
index 000000000..28026b352
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-tornado_2.2.1.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed."
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://README;md5=e7fb9954003d7cd93322ccf282210d1c"
4
5PV = "2.2.1+git${SRCPV}"
6
7SRCREV = "c501917eba46dec30b1f2ef12497dffc4beec505"
8SRC_URI = "git://github.com/facebook/tornado.git;branch=branch2.2 \
9 file://0001-disable-AI_ADDRCONFIG-flag.patch \
10"
11
12S = "${WORKDIR}/git"
13
14inherit setuptools
15
16