summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMaxin John <maxin.john@intel.com>2018-02-20 10:38:46 +0200
committerArmin Kuster <akuster808@gmail.com>2018-03-01 16:12:55 -0800
commit19c1b40b4f63ca437aaf78fa17af6fe35372478e (patch)
treec0f1d3b03f16a84553be646460f72e7687e62e6a /meta-python
parent03f79a311c79c7b43f8e47eba4c5bbe6ab532fa1 (diff)
downloadmeta-openembedded-19c1b40b4f63ca437aaf78fa17af6fe35372478e.tar.gz
python-evdev: add python3 version of the recipe
Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-evdev.inc15
-rw-r--r--meta-python/recipes-devtools/python/python-evdev_0.7.0.bb17
-rw-r--r--meta-python/recipes-devtools/python/python3-evdev_0.7.0.bb2
3 files changed, 18 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-evdev.inc b/meta-python/recipes-devtools/python/python-evdev.inc
new file mode 100644
index 000000000..ccd5077da
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-evdev.inc
@@ -0,0 +1,15 @@
1SUMMARY = "Python evdev lib"
2HOMEPAGE = "https://github.com/gvalkov/python-evdev"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=18debddbb3f52c661a129724a883a8e2"
5
6SRC_URI[md5sum] = "c7e855ae9f97f869a59e75b29f05ce74"
7SRC_URI[sha256sum] = "57edafc469a414f58b51af1bfb9ee2babb9f626dd2df530d71c1176871850aa1"
8
9RDEPENDS_${PN} += "\
10 ${PYTHON_PN}-ctypes \
11 ${PYTHON_PN}-fcntl \
12 ${PYTHON_PN}-io \
13 ${PYTHON_PN}-shell \
14 ${PYTHON_PN}-stringold \
15 "
diff --git a/meta-python/recipes-devtools/python/python-evdev_0.7.0.bb b/meta-python/recipes-devtools/python/python-evdev_0.7.0.bb
index 0875da45c..63541363e 100644
--- a/meta-python/recipes-devtools/python/python-evdev_0.7.0.bb
+++ b/meta-python/recipes-devtools/python/python-evdev_0.7.0.bb
@@ -1,17 +1,2 @@
1SUMMARY = "Python evdev lib"
2HOMEPAGE = "https://github.com/gvalkov/python-evdev"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=18debddbb3f52c661a129724a883a8e2"
5
6SRC_URI[md5sum] = "c7e855ae9f97f869a59e75b29f05ce74"
7SRC_URI[sha256sum] = "57edafc469a414f58b51af1bfb9ee2babb9f626dd2df530d71c1176871850aa1"
8
9inherit pypi setuptools 1inherit pypi setuptools
10 2require python-evdev.inc
11RDEPENDS_${PN} += "\
12 ${PYTHON_PN}-ctypes \
13 ${PYTHON_PN}-fcntl \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-shell \
16 ${PYTHON_PN}-stringold \
17 "
diff --git a/meta-python/recipes-devtools/python/python3-evdev_0.7.0.bb b/meta-python/recipes-devtools/python/python3-evdev_0.7.0.bb
new file mode 100644
index 000000000..3a92b6ec9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-evdev_0.7.0.bb
@@ -0,0 +1,2 @@
1inherit pypi setuptools3
2require python-evdev.inc