summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2014-07-15 16:32:33 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 00:01:49 +0200
commited634d36d64af846b68424d38eaa86b464584840 (patch)
treea9cc27bc6fe1a218047b72211f7c5ac3d967f651 /meta-python
parente162db22a3c77cdec97446dd3a6807405bf893cd (diff)
downloadmeta-openembedded-ed634d36d64af846b68424d38eaa86b464584840.tar.gz
meta-python: create layer
Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/COPYING.MIT17
-rw-r--r--meta-python/README53
-rw-r--r--meta-python/conf/layer.conf9
3 files changed, 79 insertions, 0 deletions
diff --git a/meta-python/COPYING.MIT b/meta-python/COPYING.MIT
new file mode 100644
index 000000000..fb950dc69
--- /dev/null
+++ b/meta-python/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-python/README b/meta-python/README
new file mode 100644
index 000000000..f62ab8fe8
--- /dev/null
+++ b/meta-python/README
@@ -0,0 +1,53 @@
1meta-python
2================================
3
4Introduction
5-------------------------
6
7This layer is intended to be the home of python modules for OpenEmbedded.
8Modules in this layer need to be independent of openembedded-core and
9meta-openembedded/meta-oe. Because of this, modules required by 'gateone'
10and 'anki' are not included and remain in:
11 meta-openembedded/meta-oe/recipes-devtools/python.
12
13Dependencies
14-------------------------
15
16The meta-python layer depends on:
17
18 URI: git://git.openembedded.org/openembedded-core
19 layers: meta
20 branch: master
21 revision: HEAD
22
23 URI: git://git.openembedded.org/meta-openembedded
24 layers: meta-oe
25 branch: master
26 revision: HEAD
27
28Please follow the recommended setup procedures of your OE distribution.
29For Angstrom that is:
30 http://www.angstrom-distribution.org/building-angstrom,
31other distros should have similar online resources.
32
33Contributing
34-------------------------
35
36The meta-openembedded mailinglist
37(openembedded-devel@lists.openembedded.org) is used for questions,
38comments and patch review. It is subscriber only, so please register
39before posting.
40
41Send pull requests to openembedded-devel@lists.openembedded.org with
42'[meta-python]' in the subject.
43
44When sending single patches, please use something like:
45'git send-email -M -1 --to=openembedded-devel@lists.openembedded.org --subject-prefix=meta-python][PATCH'
46
47Maintenance
48-------------------------
49
50Maintainers:
51 Tim "moto-timo" Orling <TicoTimo@gmail.com>
52 Paul "bluelightning" Eggleton <paul.eggleton@linux.intel.com>
53
diff --git a/meta-python/conf/layer.conf b/meta-python/conf/layer.conf
new file mode 100644
index 000000000..4e8eca3c3
--- /dev/null
+++ b/meta-python/conf/layer.conf
@@ -0,0 +1,9 @@
1# We might have a conf and classes directory, append to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have recipes directories, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
6
7BBFILE_COLLECTIONS += "meta-python"
8BBFILE_PATTERN_meta-python := "^${LAYERDIR}/"
9BBFILE_PRIORITY_meta-python = "7"