summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-07-18 02:09:11 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-24 18:58:52 +0200
commite81db0521ad7270846c1d0507caa4e4c0071e517 (patch)
tree86b4416036d5f255747df6fa03c92ccd03ec8499 /meta-python
parent6220deb3bf0daf00b16adf44f1311c77f91c9602 (diff)
downloadmeta-openembedded-e81db0521ad7270846c1d0507caa4e4c0071e517.tar.gz
python3-pid: add recipe 2.1.1
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pid/0001-remove-requirement-of-nose.patch29
-rw-r--r--meta-python/recipes-devtools/python/python3-pid_2.1.1.bb14
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pid/0001-remove-requirement-of-nose.patch b/meta-python/recipes-devtools/python/python3-pid/0001-remove-requirement-of-nose.patch
new file mode 100644
index 000000000..3beef0700
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pid/0001-remove-requirement-of-nose.patch
@@ -0,0 +1,29 @@
1From 04d04a8fa1ef3d8dbdaebbaac9ae936e1c8234c1 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Wed, 28 Jun 2017 21:17:43 -0400
4Subject: [PATCH] remove requirement of nose
5
6The nose extends unittest to make testing easier.
7Do not need the test suite, so remove requirement of nose.
8
9Upstream-Status: Inappropriate [oe specific]
10
11Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
12---
13 setup.py | 2 --
14 1 file changed, 2 deletions(-)
15
16diff --git a/setup.py b/setup.py
17index 3f7c7cb..c42a546 100644
18--- a/setup.py
19+++ b/setup.py
20@@ -53,6 +53,4 @@ setup(
21 keywords='pid pidfile context manager decorator',
22 packages=["pid"],
23 install_requires=[],
24- test_suite='nose.collector',
25- setup_requires=['nose>=1.0'],
26 )
27--
282.8.1
29
diff --git a/meta-python/recipes-devtools/python/python3-pid_2.1.1.bb b/meta-python/recipes-devtools/python/python3-pid_2.1.1.bb
new file mode 100644
index 000000000..c88d9a0b5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pid_2.1.1.bb
@@ -0,0 +1,14 @@
1SUMMARY = "Pidfile featuring stale detection and file-locking, can also \
2be used as context-manager or decorator"
3HOMEPAGE = "https://github.com/trbs/pid/"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=83d53cbd3105063f20305bc313464e29"
6
7SRC_URI[md5sum] = "9634b1e3d545544a9d496e25e4530d14"
8SRC_URI[sha256sum] = "b443169d3dc21397695b4a82016fadb4cfdb0ed8b2ddb4aaa428e1701bb34e1f"
9
10inherit pypi setuptools3
11
12SRC_URI += " \
13 file://0001-remove-requirement-of-nose.patch \
14"