summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-09-19 15:38:41 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-22 22:50:46 +0000
commitc9715e880b6d5b30ca17778f1d354b7b54ba8960 (patch)
treedf0a3a04c02da21372362c5f41782327d8b27413 /meta-python
parentbaa5f5cdf9639d661749d42b96e5222500f8c9df (diff)
downloadmeta-openembedded-c9715e880b6d5b30ca17778f1d354b7b54ba8960.tar.gz
python-bitarray: add a python3 version of the recipe
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-bitarray.inc11
-rw-r--r--meta-python/recipes-devtools/python/python-bitarray_0.8.1.bb13
-rw-r--r--meta-python/recipes-devtools/python/python3-bitarray_0.8.1.bb2
3 files changed, 15 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python-bitarray.inc b/meta-python/recipes-devtools/python/python-bitarray.inc
new file mode 100644
index 000000000..7b6e0d1b3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-bitarray.inc
@@ -0,0 +1,11 @@
1SUMMARY = "A high-level Python efficient arrays of booleans -- C extension"
2HOMEPAGE = "https://github.com/ilanschnell/bitarray"
3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3ba469353f9f2a244b2075902351e37d"
5
6SRC_URI[md5sum] = "3825184f54f4d93508a28031b4c65d3b"
7SRC_URI[sha256sum] = "7da501356e48a83c61f479393681c1bc4b94e5a34ace7e08cb29e7dd9290ab18"
8
9inherit pypi
10
11BBCLASSEXTEND = "nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-bitarray_0.8.1.bb b/meta-python/recipes-devtools/python/python-bitarray_0.8.1.bb
index 145f1fbef..f78c7abd2 100644
--- a/meta-python/recipes-devtools/python/python-bitarray_0.8.1.bb
+++ b/meta-python/recipes-devtools/python/python-bitarray_0.8.1.bb
@@ -1,11 +1,2 @@
1SUMMARY = "A high-level Python efficient arrays of booleans -- C extension" 1inherit setuptools
2HOMEPAGE = "https://github.com/ilanschnell/bitarray" 2require python-bitarray.inc
3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3ba469353f9f2a244b2075902351e37d"
5
6SRC_URI[md5sum] = "3825184f54f4d93508a28031b4c65d3b"
7SRC_URI[sha256sum] = "7da501356e48a83c61f479393681c1bc4b94e5a34ace7e08cb29e7dd9290ab18"
8
9inherit pypi setuptools
10
11BBCLASSEXTEND = "nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-bitarray_0.8.1.bb b/meta-python/recipes-devtools/python/python3-bitarray_0.8.1.bb
new file mode 100644
index 000000000..7ee444dc9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bitarray_0.8.1.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-bitarray.inc