summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-09-18 16:58:33 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-22 22:50:44 +0000
commit8d96e46f7c141ab2b632169037d06beca17e5d0b (patch)
tree5ca976dac88bb992bb75e8bec4e1f8f55c141c0a /meta-python
parent042972dfff8eebadee55a9c98ce5deb010e5d45b (diff)
downloadmeta-openembedded-8d96e46f7c141ab2b632169037d06beca17e5d0b.tar.gz
python-lxml: update to version 4.0.0
remove obsolete patch Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-lxml.inc4
-rw-r--r--meta-python/recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch40
-rw-r--r--meta-python/recipes-devtools/python/python-lxml_3.8.0.bb6
-rw-r--r--meta-python/recipes-devtools/python/python-lxml_4.0.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch40
-rw-r--r--meta-python/recipes-devtools/python/python3-lxml_3.8.0.bb6
-rw-r--r--meta-python/recipes-devtools/python/python3-lxml_4.0.0.bb2
7 files changed, 6 insertions, 94 deletions
diff --git a/meta-python/recipes-devtools/python/python-lxml.inc b/meta-python/recipes-devtools/python/python-lxml.inc
index c6ff160f8..04abe46d5 100644
--- a/meta-python/recipes-devtools/python/python-lxml.inc
+++ b/meta-python/recipes-devtools/python/python-lxml.inc
@@ -18,8 +18,8 @@ LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=e4c045ebad958ead4b48008f70838403 \
18 18
19DEPENDS += "libxml2 libxslt" 19DEPENDS += "libxml2 libxslt"
20 20
21SRC_URI[md5sum] = "e54e2fae44d684d6b9c636fe189e93ff" 21SRC_URI[md5sum] = "c30d7e752cc909c1c0c40bd34153443a"
22SRC_URI[sha256sum] = "736f72be15caad8116891eb6aa4a078b590d231fdc63818c40c21624ac71db96" 22SRC_URI[sha256sum] = "f7bc9f702500e205b1560d620f14015fec76dcd6f9e889a946a2ddcc3c344fd0"
23 23
24DISTUTILS_BUILD_ARGS += " \ 24DISTUTILS_BUILD_ARGS += " \
25 --with-xslt-config='pkg-config libxslt' \ 25 --with-xslt-config='pkg-config libxslt' \
diff --git a/meta-python/recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch b/meta-python/recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch
deleted file mode 100644
index efaecd69c..000000000
--- a/meta-python/recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From f8d2c3394767025b3b27b71248b3ecb50480cde7 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 13 Apr 2017 17:10:45 -0700
4Subject: [PATCH] lxml.etree: Add empty variadic argument
5
6format checker says that argument 4 is a printf formatted argument
7but there is no more arguments to follow
8
9Fixes libxslt format warnings
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 src/lxml/lxml.etree.c | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/src/lxml/lxml.etree.c b/src/lxml/lxml.etree.c
17index d482091..faab06c 100644
18--- a/src/lxml/lxml.etree.c
19+++ b/src/lxml/lxml.etree.c
20@@ -186086,7 +186086,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p
21 * except:
22 */
23 __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 228, __pyx_L18_except_error)
24- xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26);
25+ xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, "");
26
27 /* "src/lxml/xsltext.pxi":229
28 * c_inst_node.name, _cstr(e))
29@@ -186136,7 +186136,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p
30 * except:
31 */
32 __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 234, __pyx_L18_except_error)
33- xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26);
34+ xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, "");
35
36 /* "src/lxml/xsltext.pxi":235
37 * "Error executing extension element '%s'", c_inst_node.name)
38--
392.12.2
40
diff --git a/meta-python/recipes-devtools/python/python-lxml_3.8.0.bb b/meta-python/recipes-devtools/python/python-lxml_3.8.0.bb
deleted file mode 100644
index 5c93a3f84..000000000
--- a/meta-python/recipes-devtools/python/python-lxml_3.8.0.bb
+++ /dev/null
@@ -1,6 +0,0 @@
1inherit setuptools
2require python-lxml.inc
3
4SRC_URI = "${PYPI_SRC_URI} \
5 file://0001-lxml.etree-Add-empty-variadic-argument.patch \
6 "
diff --git a/meta-python/recipes-devtools/python/python-lxml_4.0.0.bb b/meta-python/recipes-devtools/python/python-lxml_4.0.0.bb
new file mode 100644
index 000000000..81ccb12d8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-lxml_4.0.0.bb
@@ -0,0 +1,2 @@
1inherit setuptools
2require python-lxml.inc
diff --git a/meta-python/recipes-devtools/python/python3-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch b/meta-python/recipes-devtools/python/python3-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch
deleted file mode 100644
index bb012dc44..000000000
--- a/meta-python/recipes-devtools/python/python3-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From 36e64cf2f0676ee422c1fd41456967f3015b2fa3 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 13 Apr 2017 17:10:45 -0700
4Subject: [PATCH] lxml.etree: Add empty variadic argument
5
6format checker says that argument 4 is a printf formatted argument
7but there is no more arguments to follow
8
9Fixes libxslt format warnings
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 src/lxml/lxml.etree.c | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/src/lxml/lxml.etree.c b/src/lxml/lxml.etree.c
17index d482091..faab06c 100644
18--- a/src/lxml/lxml.etree.c
19+++ b/src/lxml/lxml.etree.c
20@@ -186086,7 +186086,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p
21 * except:
22 */
23 __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 228, __pyx_L18_except_error)
24- xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26);
25+ xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, "");
26
27 /* "src/lxml/xsltext.pxi":229
28 * c_inst_node.name, _cstr(e))
29@@ -186136,7 +186136,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p
30 * except:
31 */
32 __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 234, __pyx_L18_except_error)
33- xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26);
34+ xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, "");
35
36 /* "src/lxml/xsltext.pxi":235
37 * "Error executing extension element '%s'", c_inst_node.name)
38--
392.12.2
40
diff --git a/meta-python/recipes-devtools/python/python3-lxml_3.8.0.bb b/meta-python/recipes-devtools/python/python3-lxml_3.8.0.bb
deleted file mode 100644
index 8b13d2dd2..000000000
--- a/meta-python/recipes-devtools/python/python3-lxml_3.8.0.bb
+++ /dev/null
@@ -1,6 +0,0 @@
1inherit setuptools3
2require python-lxml.inc
3
4SRC_URI = "${PYPI_SRC_URI} \
5 file://0001-lxml.etree-Add-empty-variadic-argument.patch \
6 "
diff --git a/meta-python/recipes-devtools/python/python3-lxml_4.0.0.bb b/meta-python/recipes-devtools/python/python3-lxml_4.0.0.bb
new file mode 100644
index 000000000..ff4bc7faa
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-lxml_4.0.0.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-lxml.inc