summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2017-10-04 14:02:34 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-10-15 17:29:29 +0000
commit328156b2b070b411e4ce7ad45a3e9c43b54dfc28 (patch)
tree4588a4959e9de656893052b90661f6e84d3875a1 /meta-python
parent5205419c229c866b20c5a8a79d41de4879802bd3 (diff)
downloadmeta-openembedded-328156b2b070b411e4ce7ad45a3e9c43b54dfc28.tar.gz
python3-protobuf: add python3 version
Signed-off-by: Pascal Bach <pascal.bach@nextrem.ch> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-protobuf.inc16
-rw-r--r--meta-python/recipes-devtools/python/python-protobuf_3.4.0.bb18
-rw-r--r--meta-python/recipes-devtools/python/python3-protobuf_3.4.0.bb2
3 files changed, 20 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-protobuf.inc b/meta-python/recipes-devtools/python/python-protobuf.inc
new file mode 100644
index 000000000..2f59ef98b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-protobuf.inc
@@ -0,0 +1,16 @@
1DESCRIPTION = "Protocol Buffers"
2HOMEPAGE = "https://developers.google.com/protocol-buffers/"
3SECTION = "devel/python"
4
5RDEPENDS_${PN} = "python-six"
6
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
9
10inherit pypi
11
12SRC_URI[md5sum] = "bfc0c61c156a995e909521697e755780"
13SRC_URI[sha256sum] = "ef02609ef445987976a3a26bff77119c518e0915c96661c3a3b17856d0ef6374"
14
15# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
16BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python-protobuf_3.4.0.bb b/meta-python/recipes-devtools/python/python-protobuf_3.4.0.bb
index cde62b74a..f04fc489f 100644
--- a/meta-python/recipes-devtools/python/python-protobuf_3.4.0.bb
+++ b/meta-python/recipes-devtools/python/python-protobuf_3.4.0.bb
@@ -1,16 +1,2 @@
1DESCRIPTION = "Protocol Buffers" 1inherit setuptools
2HOMEPAGE = "https://developers.google.com/protocol-buffers/" 2require python-protobuf.inc
3SECTION = "devel/python"
4
5RDEPENDS_${PN} = "python-six"
6
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
9
10inherit pypi setuptools
11
12SRC_URI[md5sum] = "bfc0c61c156a995e909521697e755780"
13SRC_URI[sha256sum] = "ef02609ef445987976a3a26bff77119c518e0915c96661c3a3b17856d0ef6374"
14
15# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
16BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-protobuf_3.4.0.bb b/meta-python/recipes-devtools/python/python3-protobuf_3.4.0.bb
new file mode 100644
index 000000000..781d1dc4d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-protobuf_3.4.0.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-protobuf.inc